Bug 6324 - Very unstable PPP setup
Very unstable PPP setup
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: initscripts (Show other bugs)
6.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael K. Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-10-25 03:50 EDT by Pim Vijfhuizen
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-11-22 18:03:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pim Vijfhuizen 1999-10-25 03:50:14 EDT
Hello Bugzilla,

I've installed RH 6.1 on my test partition, and it shows a
very unstable PPP dial setup. I've configured the PPP items
just like the production RH 6.0 system, using netconf. I've
repeatedly checked all settings but the problem remains. The
RH 6.1 system fails to connect to my ISP, restarting the
pppd daemon incessantly. In the /var/log/messages file I see
 complaints about pppd not being able to find a suitable
secret to authenticate the link. Occasionally it does
connect (odd) but most of the time netconf says after 15
seconds that the ifup-watch program has failed and asks me
to kill it. I believe this is caused by the new initscripts,
but I haven't demonstrated that.

Kind regards,
Pim Vijfhuizen.
Comment 1 Anonymous 1999-11-16 10:56:59 EST
I have the same problem.
A workaround to this is to add
noauth
to PPP options (there is an option for this in netconf)
After this workaround pppd usually works more or less OK.
Comment 2 Michael K. Johnson 1999-11-19 15:15:59 EST
The next release of initscripts will fix this problem by using "noauth"
automatically in this case.  For now, you can add noauth to the extra
PPP options as Pim suggests.

The problem is that pppd's behaviour regarding CHAP authentication appears
to have changed.
Comment 3 Michael K. Johnson 1999-11-22 18:03:59 EST
In the process of releasing initscripts-4.67, which will fix this.

Note You need to log in before you can comment on or make changes to this bug.