Bug 632412 - Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0)
Summary: Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0)
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 13
Hardware: i686
OS: Linux
low
high
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-09-09 20:57 UTC by Tom Van Vleck
Modified: 2017-11-09 17:56 UTC (History)
19 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-12-10 19:45:07 UTC


Attachments (Terms of Use)

Description Tom Van Vleck 2010-09-09 20:57:51 UTC
Description of problem:
Did a standard yum update, new kernel 2.6.34.6-54.fc13.i686.PAE was installed.
Rebooted. Got black screen with the message
 Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0)
Went back to 2.6.34.6-47.fc13.i686.PAE and it boots ok.

Version-Release number of selected component (if applicable):
2.6.34.6-54.fc13.i686.PAE

How reproducible:
Happens every time I boot from this kernel.

Steps to Reproduce:
1. yum update to install kernel 2.6.34.6-54.fc13.i686.PAE
2. reboot
  
Actual results:
Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0)

Expected results:
normal boot

Additional info:
This machine is an Acer set up to dual boot Windows 7 and Linux.

following is output of fdisk -l

Disk /dev/sda: 750.2 GB, 750156374016 bytes
255 heads, 63 sectors/track, 91201 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0xa7fbbb3a

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1               1        1785    14336000   27  Unknown
/dev/sda2   *        1785        1798      102400    7  HPFS/NTFS
/dev/sda3            1798       24745   184324788+   7  HPFS/NTFS
/dev/sda4           24746       91201   533807820    5  Extended
/dev/sda5           24746       24771      204800   83  Linux
/dev/sda6           24771       91201   533602303+  8e  Linux LVM

Disk /dev/dm-0: 541.6 GB, 541606281216 bytes
255 heads, 63 sectors/track, 65846 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x00000000


Disk /dev/dm-1: 4798 MB, 4798283776 bytes
255 heads, 63 sectors/track, 583 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x00000000

Comment 1 Christian Schaller 2010-09-12 17:11:12 UTC
Getting the same error message, smolt profile here:
http://www.smolts.org/client/show/pub_f32b1f6f-d9c3-4ef1-91a9-e88b5ea89498

The kernel we got that works is this one, not 2.6.34 kernel have worked on this laptop:
2.6.33.5-122

Comment 2 Chuck Ebbert 2010-09-13 20:44:51 UTC
This may be due to a bug in a recent udev update. Try updating the system and then rebuilding the initrd for that kernel.

Comment 3 Tim Jackson 2010-09-20 07:57:22 UTC
I have the same issue with an MSI U100. Kernel 2.6.34.6-47.fc13.i686 works, but not 2.6.34.6-54.fc13.i686

Comment 4 Ranjan Maitra 2010-09-22 15:38:36 UTC
same problem with 2.6.34.7-56.fc13.x86_64, on a Thinkpad T61. This seems to be a serious issue.

Comment 5 Tim Jackson 2010-09-22 22:22:32 UTC
2.6.34.7-56.fc13.i686 fixes it for me on my MSI Wind U100.

Comment 6 Tom Van Vleck 2010-09-23 01:44:51 UTC
Kernel 2.6.34.7-56.i686.PAE updated by yum fixed this problem for me on my Acer Aspire AX1800-U9002.

Comment 7 Ranjan Maitra 2010-09-25 04:30:19 UTC
So, I tried the following:

I went back to 2.6.33.5-122 and removed all the other more recent kernels. Then I installed the latest 2.6.34.7-56.x86_64 and this time, it rebooted fine, no problem.

The problem has cropped up over the last three kernels. If I update fine from a lower kernel, there is not a problem, but from these it yields the kernel panic. 
I believe this problem was introduced in the previous two kernels and has not gone away. Something there has changed (please consider the changes from the last three 2.6.34 kernels relative to the ones previous to it).

Comment 8 Frank 2010-10-06 06:04:54 UTC
Same kernel panic with new kernel 2.6.34.7-56.fc13.x86-64 after a yum upgrade. Previous Kernel works.

Comment 9 Dashke 2010-10-11 19:39:32 UTC
Yup, same problem after update to new kernel - 2.6.34.7-56.fc13.

Comment 10 Todd R. 2010-11-08 16:42:00 UTC
I get the same message for FC14 with kernel, 2.6.35.6-48.fc14.x86_64 but can boot fine on the FC13 kernel.

However I can get around the panic when booting FC14 by modifying the 'kernel' line in grub at boot.  I replaced 'root=UUID=XXXXX....X' with 'root=/dev/sda8'

This allows FC14 to boot but does enter the following into /var/log/dmesg

[    1.529302] EXT3-fs (sda8): error: couldn't mount because of unsupported optional features (240)
[    1.567518] EXT4-fs (sda8): mounted filesystem with ordered data mode. Opts: (null)
[    1.567529] VFS: Mounted root (ext4 filesystem) readonly on device 8:8.
.
.
.
[   12.783050] EXT4-fs (sda8): re-mounted. Opts: (null)


This is from /boot/grub/grub.conf:

title Fedora (2.6.35.6-48.fc14.x86_64)
	root (hd0,7)
	kernel /boot/vmlinuz-2.6.35.6-48.fc14.x86_64 ro root=UUID=222e0926-2738-4f73-b710-69aadd5dee73 rd_NO_LUKS rd_NO_LVM rd_NO_MD rd_NO_DM LANG=en_US.UTF-8 SYSFONT=latarcyrheb-sun16 KEYTABLE=us rhgb quiet nouveau.modeset=0 rdblacklist=nouveau vga=893 insmod=ext4
title Fedora (2.6.34.7-61.fc13.x86_64)
	root (hd0,7)
	kernel /boot/vmlinuz-2.6.34.7-61.fc13.x86_64 ro root=UUID=222e0926-2738-4f73-b710-69aadd5dee73 rd_NO_LUKS rd_NO_LVM rd_NO_MD rd_NO_DM LANG=en_US.UTF-8 SYSFONT=latarcyrheb-sun16 KEYTABLE=us rhgb quiet nouveau.modeset=0 rdblacklist=nouveau vga=893

Output of 'mount' in FC13 (I'm in FC13 atm)
/dev/sda8 on / type ext4 (rw)
proc on /proc type proc (rw)
sysfs on /sys type sysfs (rw)
devpts on /dev/pts type devpts (rw,gid=5,mode=620)
tmpfs on /dev/shm type tmpfs (rw)
none on /proc/sys/fs/binfmt_misc type binfmt_misc (rw)
sunrpc on /var/lib/nfs/rpc_pipefs type rpc_pipefs (rw)
fusectl on /sys/fs/fuse/connections type fusectl (rw)
gvfs-fuse-daemon on /home/todd/.gvfs type fuse.gvfs-fuse-daemon (rw,nosuid,nodev,user=todd)

A list of disk UUID's (note that sda8 DOES match the grub line):
                           07D8-0402 -> ../../sda1
222e0926-2738-4f73-b710-69aadd5dee73 -> ../../sda8
                    4A54405954404A41 -> ../../sdb2
                    9A2C85422C851A81 -> ../../sda2
                           A688-593E -> ../../sda5
a6b7f429-c35a-36df-bafa-d864b2b42eb3 -> ../../sdb1
                    AEA481AEA4817A1B -> ../../sda7
ec01afcb-c956-4ada-8624-732076844648 -> ../../sda6

Output of 'fdisk -l /dev/sda':

Disk /dev/sda: 500.1 GB, 500107862016 bytes
255 heads, 63 sectors/track, 60801 cylinders, total 976773168 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x0008c8a2

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1              63      417689      208813+   6  FAT16
/dev/sda2   *      417690   614823614   307202962+   7  HPFS/NTFS
/dev/sda3       614823615   737704799    61440592+  af  HFS / HFS+
/dev/sda4       737704800   976768064   119531632+   f  W95 Ext'd (LBA)
/dev/sda5       737704863   746106794     4200966   dd  Unknown
/dev/sda6       746106858   754508789     4200966   82  Linux swap / Solaris
/dev/sda7       754508853   796454504    20972826   dc  Unknown
/dev/sda8       796454568   976768064    90156748+  83  Linux

For now I will modify my grub.conf to use /dev/sda8 vs the UUID.

Comment 11 Ash 2010-11-30 09:14:18 UTC
I got the same bug/error when I upgraded from fc13 (2.6.34.7-61.gc13.x86_64) to fc14 (2.6.35.6-48.fc14.x86_64).

Replacing the uuid with /dev/sda1 (in may case) produces the same error.

First two lines of error
0.834209 Kernel Panic - not Syncing : VFS : Unable to mount fs on unknown-blcok(0,0)
....,  Pid : 1 , com: swapper Not tainted 2.6.35.6-48.fc14.x86_64 #1

Comment 12 Ash 2010-12-03 05:51:09 UTC
Further Debug:
I think the issue is after the first boot after upgrade. Apparently the kernel img file should have been created/moved (from /boot upgrade dir) for normal fc14 boot. The file is non-existent.  I see fc13 img files only.

/boot/initramfs-2.6.34.7-61.fc13.x86_64.debug.img
/boot/initramfs-2.6.34.7-61.fc13.x86_64.img
/boot/initramfs-2.6.34.7-56.fc13.x86_64.img
/boot/initramfs-2.6.33.3-85.fc13.x86_64.img

no fc14 img file.

See the first few linesnew grub.conf after upgrade.
# grub.conf generated by anaconda
#
# Note that you do not have to rerun grub after making changes to this file
# NOTICE:  You do not have a /boot partition.  This means that
#          all kernel and initrd paths are relative to /, eg.
#          root (hd0,0)
#          kernel /boot/vmlinuz-version ro root=/dev/sda1
#          initrd /boot/initrd-[generic-]version.img
#boot=/dev/sda
default=0
timeout=3
splashimage=(hd0,0)/boot/grub/splash.xpm.gz
hiddenmenu

title Fedora (2.6.35.6-48.fc14.x86_64)
	root (hd0,0)
	kernel /boot/vmlinuz-2.6.35.6-48.fc14.x86_64 ro root=/dev/sda1 rd_NO_LUKS rd_NO_LVM rd_NO_MD rd_NO_DM LANG=en_US.UTF-8 SYSFONT=latarcyrheb-sun16 KEYTABLE=us rhgb quiet
	initrd /boot/vmlinuz-2.6.35.6-48.fc14.x86_64.img

The last file /boot/vmlinuz-2.6.35.6-48.fc14.x86_64.img is missing.

Because of this, the FC14 boot never initiates for subsequent runs.Changed grub.conf to pick default =3 to pick fc13

Comment 13 Kyle McMartin 2010-12-10 19:45:07 UTC
Run dracut to regenerate your initramfs, the kernel can't boot if that file doesn't exist, and it's certainly configured to set one up on install, but for some reason it wasn't generated in your case.

Either way, running dracut to generate a /boot/initrd-version.img should sort things out.

--Kyle


Note You need to log in before you can comment on or make changes to this bug.