Bug 63244 - Cannot get service name / ID
Cannot get service name / ID
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: clumanager (Show other bugs)
2.1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jason Baron
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-04-11 13:21 EDT by Tim Burke
Modified: 2013-03-06 00:55 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-06-11 18:22:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tim Burke 2002-04-11 13:21:24 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.2.1) Gecko/20010901

Description of problem:
The cluster logs have frequent occurrances of can't get service name or ID.  For
example, someone said they run scripts which start/stop services and lots of
these errors appear in the log.

-------------------------------------------
I noticed that one gets entered into the log during service creation.  It
appears in the cluadmin sequence shown below.
Service name: dummy1
Preferred member [None]: 
User script (e.g., /usr/foo/script or None) [None]: 
Status check interval [0]: 
Do you want to add an IP address to the service (yes/no/?) [no]: 
Do you want to add a disk device to the service (yes/no/?) [no]: 
name: dummy1
preferred node: None
user script: None
monitor interval: 0
Add dummy1 service as shown? (yes/no/?) yes
  0) prod1
  1) prod2
  c) cancel

Choose member to start service on: 
<<< This is where the following log message appears>>>

Apr 11 11:11:14 prod1 clusvcmgrd[15404]: <warning> Cannot get service name for
service #2 
(could this be another resarray delight?)
--------------------------------------------------------------
Here's some other occurrances in the log on the same system.

One thing that is troubling is the perposterously large service numbers, eg: 
#1075669904
[root@prod1 root]# grep "Cannot get service" /var/log/cluster
Apr 10 13:58:23 prod1 clusvcmgrd[17170]: <warning> Cannot get service name for
service #4 
Apr 10 15:22:36 prod1 clusvcmgrd[17170]: <warning> Cannot get service name for
service #2 
Apr 10 15:30:54 prod1 clusvcmgrd[17170]: <warning> Cannot get service name for
service #5 
Apr 10 15:39:31 prod1 cluadmin[27507]: <err> Cannot get service ID for service
u5 from database: not found 
Apr 10 15:39:31 prod1 cluadmin[27507]: <err> Cannot get service ID for service
u5 from database: not found 
Apr 10 15:39:31 prod1 cluadmin[27507]: <warning> Cannot get service name for
service #1075669904 
Apr 10 15:40:23 prod1 cluadmin[27507]: <err> Cannot get service ID for service
u5 from database: not found 
Apr 10 15:40:23 prod1 cluadmin[27507]: <err> Cannot get service ID for service
u5 from database: not found 
Apr 10 15:40:23 prod1 cluadmin[27507]: <warning> Cannot get service name for
service #1075669904 
Apr 10 15:40:26 prod1 cluadmin[27507]: <err> Cannot get service ID for service
u5 from database: not found 
Apr 10 15:40:26 prod1 cluadmin[27507]: <err> Cannot get service ID for service
u5 from database: not found 
Apr 10 15:40:26 prod1 cluadmin[27507]: <warning> Cannot get service name for
service #1075669904 
Apr 10 15:40:41 prod1 cluadmin[27507]: <err> Cannot get service ID for service
krap from database: not found 
Apr 10 15:40:41 prod1 cluadmin[27507]: <err> Cannot get service ID for service
krap from database: not found 
Apr 10 15:40:41 prod1 cluadmin[27507]: <warning> Cannot get service name for
service #1075669904 
Apr 10 15:40:56 prod1 cluadmin[27507]: <err> Cannot get service ID for service
krap from database: not found 
Apr 10 15:40:56 prod1 cluadmin[27507]: <err> Cannot get service ID for service
krap from database: not found 
Apr 10 15:40:56 prod1 cluadmin[27507]: <warning> Cannot get service name for
service #1075669904 


Version-Release number of selected component (if applicable):


How reproducible:
Sometimes

Steps to Reproduce:
1.Add a new service.
2.Observe the message in the logs.
3.
	

Actual Results:  Ominous log messages.

Expected Results:  No log messages.

Additional info:
Comment 1 Jason Baron 2002-04-16 10:02:58 EDT
The "Cannot get service name" that occurs on service adds, is due
to a "boot-strapping" issue.  The svcmgrd puts out this warning 
message because the database has not been written yet.   
Comment 2 Lon Hohberger 2002-06-11 17:59:45 EDT
These messages still appear in the current pool, excepting the ones which seem
to be pointer values:

Apr 10 15:40:23 prod1 cluadmin[27507]: <warning> Cannot get service name for
service #1075669904

These _were_ a result of a bug, but no longer occur.

The cluadmin warnings/errors seen should not have been warnings or errors. 
Cluadmin uses the functions generating these errors to find the first available
service IDs.  I'm changing these messages to debug, since they will likely cause
alarm (though they clearly should not).

Fix for this part in pool, waiting on Jason for second half.

Comment 3 Jason Baron 2002-06-11 18:22:28 EDT
Fixed the "Cannot get service name" that occur on service adds
Comment 4 Lon Hohberger 2002-06-14 10:08:14 EDT
Fixes in pool.

Note You need to log in before you can comment on or make changes to this bug.