Bug 63262 - HTTP_POST_VARS not available in binary mode
Summary: HTTP_POST_VARS not available in binary mode
Status: CLOSED CANTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: php   
(Show other bugs)
Version: 7.2
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Joe Orton
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-04-11 20:03 UTC by Ray Parish
Modified: 2007-04-18 16:41 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-18 16:55:52 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Ray Parish 2002-04-11 20:03:22 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)

Description of problem:
I have php installed in cgi binary mode. When calling a php script from apache 
and using POST, HTTP_POST_VARS are null

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. installed php-4.0.6-15 (rebuilt from php-4.0.6-15.src.rpm)
2. configure apache to parse php files
3. <? echo $HTTP_POST_VARS['field1']; ?>
4. Get nothign
	

Actual Results:  HTTP_POST_VARS is an array, but stepping thru the array 
reveals a NULL array.

Expected Results:  HTTP_POST_VARS to be available since register_globals is On 
in the /etc/php.ini

Additional info:

Comment 1 Ray Parish 2002-04-11 20:05:28 UTC
We have customers that want to run the binary php scripts out of the /cgi-bin 
directory. So we rebuild the src.rpm and take out the --force-cgi-redirect.
Now customers can not get POST information from forms 
HTTP_POST_VARS
only thing that works is telling tht customer to use GET instead of POST
HTTP_GET_VARS




Comment 2 Ray Parish 2002-06-19 00:07:39 UTC
Hey, Any updates?

Comment 3 Bill Nottingham 2006-08-07 19:37:42 UTC
Red Hat Linux is no longer supported by Red Hat, Inc. If you are still
running Red Hat Linux, you are strongly advised to upgrade to a
current Fedora Core release or Red Hat Enterprise Linux or comparable.
Some information on which option may be right for you is available at
http://www.redhat.com/rhel/migrate/redhatlinux/.

Red Hat apologizes that these issues have not been resolved yet. We do
want to make sure that no important bugs slip through the cracks.
Please check if this issue is still present in a current Fedora Core
release. If so, please change the product and version to match, and
check the box indicating that the requested information has been
provided. Note that any bug still open against Red Hat Linux on will be
closed as 'CANTFIX' on September 30, 2006. Thanks again for your help.


Comment 4 Bill Nottingham 2006-10-18 16:55:52 UTC
Red Hat Linux is no longer supported by Red Hat, Inc. If you are still
running Red Hat Linux, you are strongly advised to upgrade to a
current Fedora Core release or Red Hat Enterprise Linux or comparable.
Some information on which option may be right for you is available at
http://www.redhat.com/rhel/migrate/redhatlinux/.

Closing as CANTFIX.


Note You need to log in before you can comment on or make changes to this bug.