Bug 63265 - missing VideoRam line in /etc/X11/XF86Config-4
Summary: missing VideoRam line in /etc/X11/XF86Config-4
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: anaconda (Show other bugs)
(Show other bugs)
Version: skipjack-beta2
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Michael Fulbright
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-04-11 20:24 UTC by David Paschal
Modified: 2007-04-18 16:41 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-11 20:25:04 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description David Paschal 2002-04-11 20:24:57 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.72 [en] (X11; U; Linux 2.2.18-dsp1 i686)

Description of problem:
anaconda doesn't put "VideoRam" line in 'Section "Device"' in file
/etc/X11/XF86Config-4.  (It does for /tmp/XF86Config.test and
/etc/X11/XF86Config.)

This is a problem for me, because I use 8MB Matrox Millennium II cards, for
which XFree86 is unable to probe the video RAM size due to a hardware bug and
defaults to 4MB.  Even
though I specify 8MB, if the setting doesn't get saved into the configuration
file, I am unable to use the higher-resolution modes with this card unless I
manually edit the configuration file, which many users wouldn't know to do.

Xconfigurator has a similar issue, and I'll log a defect against it too.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install on a machine with an 8MB Matrox Millennium video card.
2. Specify 8MB video RAM and a video mode that requires that much RAM, such as
1280x1024x24.

Actual Results:  XFree86 4.x refuses to do a mode higher than 1152x864x24,
because it assumes 4MB of video RAM unless told otherwise.

Expected Results:  If XFree86 4.x had been told that there was 8MB video RAM,
then it would have used the higher-resolution mode that I selected, such as
1280x1024x24.

Additional info:

Comment 1 Jeremy Katz 2002-04-11 22:20:20 UTC
This is because the general case is that setting the video ram explicitly for
XFree 4 is the wrong thing to do and there's no real way to know what the few
exceptions are that need it written out.


Note You need to log in before you can comment on or make changes to this bug.