Bug 632738 - [6.1 FEAT] Package Update: libvpd
[6.1 FEAT] Package Update: libvpd
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: libvpd (Show other bugs)
6.1
All All
medium Severity medium
: beta
: 6.1
Assigned To: Jiri Skala
qe-baseos-daemons
: FutureFeature, OtherQA, Rebase
Depends On:
Blocks: 538808 580566
  Show dependency treegraph
 
Reported: 2010-09-10 16:42 EDT by IBM Bug Proxy
Modified: 2014-11-09 17:33 EST (History)
9 users (show)

See Also:
Fixed In Version: libvpd-2.1.2-1.el6
Doc Type: Rebase: Bug Fixes and Enhancements
Doc Text:
There are only little code optimizations (no ChangeLog items)
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-05-19 08:59:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
IBM Linux Technology Center 67141 None None None Never

  None (edit)
Description IBM Bug Proxy 2010-09-10 16:42:58 EDT
1. Feature Overview:
Feature Id: [67141]
a. Name of Feature: [6.1 FEAT] Package Update: libvpd
b. Feature Description
libvpd provides the API by which many different tools access System hardware inventories and status.
 This request is to update libvpd

Source code can be obtained from: 
http://sourceforge.net/projects/linux-diag/files/libvpd/


2. Feature Details:
Sponsor: LTC RAS
Architectures:
  ppc64, 

Arch Specificity: purely common code
Affects Kernel Modules: Field does not exist
Delivery Mechanism: Direct from Community
Category: system management
Request Type: Package - Update Version
d. Upstream Acceptance: Field does not exist
Sponsor Priority P3
f. Severity: normal
IBM Confidential: No
Code Contribution: IBM code
g. Component Version Target:
---

3. Business Case
libvpd provides the API by which external serviceability and diagnostics tools can access Vital
Product Data, consisting of hardware present on a system, the characteristics of that hardware, and
hardware state.  It is used by many other tools, some of which include ppc64-diag (for which a
package add request will also be provided), IBM Director, and lsvpd (for which a package add request
will also be provided).

4. Primary contact at Red Hat:
John Jarvis
jjarvis@redhat.com

5. Primary contacts at Partner:
Project Management Contact:
Michael W. Wortman, wortman@us.ibm.com

Technical contact(s):
BRAD PETERS, bpeters@us.ibm.com
Comment 3 IBM Bug Proxy 2010-10-04 12:31:00 EDT
------- Comment From rsisk@us.ibm.com 2010-10-04 10:42 EDT-------
Code Upstream Status: No Code Required
Comment 7 John Jarvis 2010-12-01 11:29:28 EST
This enhancement request was evaluated by the full Red Hat Enterprise Linux 
team for inclusion in a Red Hat Enterprise Linux minor release.   As a 
result of this evaluation, Red Hat has tentatively approved inclusion of 
this feature in the next Red Hat Enterprise Linux Update minor release.   
While it is a goal to include this enhancement in the next minor release 
of Red Hat Enterprise Linux, the enhancement is not yet committed for 
inclusion in the next minor release pending the next phase of actual 
code integration and successful Red Hat and partner testing.
Comment 8 Jiri Skala 2011-01-07 03:26:24 EST
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
There are only little code optimizations (no ChangeLog items)
Comment 10 Jiri Skala 2011-01-18 04:13:30 EST
(In reply to comment #3)
> ------- Comment From rsisk@us.ibm.com 2010-10-04 10:42 EDT-------
> Code Upstream Status: No Code Required

What did you mentioned with this status?

There is libvpd-2.1.1 in RHEL6 and latest upstream is libvpd-2.1.2. The 2.1.2 version seems to be a bit corrupted (lib numbering, libtool version - currently investigated).

Which version did you mentioned as a right one?
Comment 12 Chris Ward 2011-04-06 07:08:12 EDT
~~ Partners and Customers ~~

This bug was included in RHEL 6.1 Beta. Please confirm the status of this request as soon as possible.

If you're having problems accessing 6.1 bits, are delayed in your test execution or find in testing that the request was not addressed adequately, please let us know.

Thanks!
Comment 13 Stephanie Glass 2011-05-11 15:54:43 EDT
This has been tested and verified by IBM.
Comment 14 errata-xmlrpc 2011-05-19 08:59:48 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2011-0548.html

Note You need to log in before you can comment on or make changes to this bug.