Bug 63305 - undefined symbol: atexit
undefined symbol: atexit
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: glibc (Show other bugs)
skipjack-beta2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
Brian Brock
:
: 63404 (view as bug list)
Depends On:
Blocks: 61590
  Show dependency treegraph
 
Reported: 2002-04-12 03:05 EDT by Nathan G. Grennan
Modified: 2007-04-18 12:41 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-15 11:43:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Requested out from readelf -a /usr/bin/vmware-ping (10.14 KB, text/plain)
2002-04-12 04:20 EDT, Nathan G. Grennan
no flags Details

  None (edit)
Description Nathan G. Grennan 2002-04-12 03:05:51 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020408

Description of problem:
Apr 12 01:33:24 cygnusx-1 VMware[init]: /usr/bin/vmware-ping: relocation error:
/usr/bin/vmware-ping: undefined symbol: atexit
Apr 12 01:33:24 cygnusx-1 VMware[init]: /usr/bin/vmnet-netifup: relocation
error: /usr/bin/vmnet-netifup: undefined symbol: atexit
Apr 12 01:33:24 cygnusx-1 VMware[init]: /usr/bin/vmware-ping: relocation error:
/usr/bin/vmware-ping: undefined symbol: atexit
Apr 12 01:33:24 cygnusx-1 VMware[init]: /usr/bin/vmnet-netifup: relocation
error: /usr/bin/vmnet-netifup: undefined symbol: atexit

I see these in my /var/log/messages after running vmware-config.pl and it
failing to run the above programs. This worked fine with 2.2.5-30, but today's
release of 2.2.5-32 causes this problem.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install Skipjack beta2
2. up2date -u
3. Install VMware 3.1.1 build 1790
4. Run vmware-config.pl
5. tail -20 /var/log/messages
	

Actual Results:  Apr 12 01:33:24 cygnusx-1 VMware[init]: /usr/bin/vmware-ping:
relocation error: /usr/bin/vmware-ping: undefined symbol: atexit
Apr 12 01:33:24 cygnusx-1 VMware[init]: /usr/bin/vmnet-netifup: relocation
error: /usr/bin/vmnet-netifup: undefined symbol: atexit
Apr 12 01:33:24 cygnusx-1 VMware[init]: /usr/bin/vmware-ping: relocation error:
/usr/bin/vmware-ping: undefined symbol: atexit
Apr 12 01:33:24 cygnusx-1 VMware[init]: /usr/bin/vmnet-netifup: relocation
error: /usr/bin/vmnet-netifup: undefined symbol: atexit


Expected Results:  The programs to run without any error messages in
/var/log/messages.

Additional info:
Comment 1 Jakub Jelinek 2002-04-12 04:04:08 EDT
Can you please attach output of
readelf -a /usr/bin/vmware-ping
?
Thanks.
Comment 2 Nathan G. Grennan 2002-04-12 04:20:03 EDT
Created attachment 53604 [details]
Requested out from   readelf -a /usr/bin/vmware-ping
Comment 3 Michael Young 2002-04-12 09:52:18 EDT
I see the same error when I try to run RealPlayer 8.
Comment 4 Olivier Baudron 2002-04-13 08:32:46 EDT
Same error with xawtv, when I upgraded glibc from -30 to -32.
Comment 5 Jay Berkenbilt 2002-04-13 12:27:51 EDT
This appears to happen with executables compiled with older library versions. 
It also appears to be that executables compiled with this version of the library
won't run on a RedHat 7.2 system.  I will post more useful and exact details
when I'm back in front of my skipjack machine.
Comment 6 Bill Nottingham 2002-04-14 23:53:01 EDT
*** Bug 63404 has been marked as a duplicate of this bug. ***
Comment 7 Need Real Name 2002-04-15 11:42:40 EDT
pgp software also exhibits this problem.
Comment 8 Need Real Name 2002-04-15 11:43:49 EDT
And, OOHHHHH, my Quake II doesn't ru anymore, it really needs atexit()!!! :-)
Comment 9 Jakub Jelinek 2002-04-15 11:46:44 EDT
Should be fixed in glibc-2.2.5-33.
Comment 10 Knut J BJuland 2002-04-18 02:41:49 EDT
when'll glibc 2.2.5-34 or 33 be aviable.

Note You need to log in before you can comment on or make changes to this bug.