Bug 63320 - RFE: have /sbin/installkernel check for modules
RFE: have /sbin/installkernel check for modules
Status: CLOSED NOTABUG
Product: Red Hat Public Beta
Classification: Retired
Component: mkinitrd (Show other bugs)
skipjack-beta2
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Matt Wilson
David Lawrence
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-04-12 11:47 EDT by Chris Adams
Modified: 2007-03-26 23:52 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-12 11:47:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Chris Adams 2002-04-12 11:47:40 EDT
It would be nice for /sbin/installkernel check to see that the corresponding
modules have been installed before doing anything, since new-kernel-pkg is
called with --mkinitrd and --depmod (which won't work if the modules aren't
installed).  

Something like:

if [ ! -e /lib/modules/$KERNEL_VERSION ]; then
        echo "Run 'make modules_install' before 'make install'" 1>&2
        exit 1
fi

near the top before any action is taken would do it.

I do this in the wrong order sometimes, and a simple check would help.
Comment 1 Erik Troan 2002-05-21 18:58:50 EDT
what if you build a completely monolithic kernel?

Note You need to log in before you can comment on or make changes to this bug.