Bug 633226 - when changing orientation of screen Xorg crashes (NVS 3100)
when changing orientation of screen Xorg crashes (NVS 3100)
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: xorg-x11-drv-nouveau (Show other bugs)
6.1
All Linux
low Severity high
: rc
: ---
Assigned To: Ben Skeggs
desktop-bugs@redhat.com
: Rebase, Triaged
Depends On:
Blocks: 647899
  Show dependency treegraph
 
Reported: 2010-09-13 06:14 EDT by Vladimir Benes
Modified: 2011-05-19 09:11 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Rebase: Bug Fixes and Enhancements
Doc Text:
This field is the basis of the errata or release note for this bug. It can also be used for change logs. The Technical Note template, known as CCFR, is as follows: Cause What actions or circumstances cause this bug to present. Consequence What happens when the bug presents. Fix What was done to fix the bug.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-05-19 09:11:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
sos report from abrt (282.46 KB, application/x-xz)
2010-09-13 06:17 EDT, Vladimir Benes
no flags Details

  None (edit)
Description Vladimir Benes 2010-09-13 06:14:50 EDT
Description of problem:
when changing orientation using display properties Xorg crashes. No matter if primary or secondary display is rotated

doesn't affect NVS 290 but only NVS 3100

Version-Release number of selected component (if applicable):
xorg-x11-drv-nouveau-0.0.16-8.20100423git13c1043.el6.x86_64
kernel-2.6.32-71.el6.x86_64

How reproducible:


Steps to Reproduce:
1.go into gnome display properties
2.rotate display
3.
  
Actual results:
crash

Expected results:
no crash

Additional info:
Comment 1 Vladimir Benes 2010-09-13 06:17:01 EDT
Created attachment 446880 [details]
sos report from abrt
Comment 2 Matěj Cepl 2010-09-13 18:47:05 EDT
(In reply to comment #1)
> Created attachment 446880 [details]
> sos report from abrt

It's weird but there are many pieces of information which are not part of the sosreport:

* your X server config file (/etc/X11/xorg.conf, if available) -- I guess there is none, right?
* X server log file (/var/log/Xorg.*.log) -- yes, even that is missing
* output of the dmesg command, and
* system log (/var/log/messages)

Please attach these logs to the bug report as individual uncompressed file attachments using the bugzilla file attachment link above.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 3 Ben Skeggs 2011-01-06 22:52:17 EST
The xorg-x11-drv-nouveau rebase is now sitting in CVS, and should resolve this problem.  It can't be built in brew yet however as it's pending a libdrm update.
Comment 6 Vladimir Benes 2011-03-10 05:47:37 EST
hmm, I can again see occasional lock ups no related to screen orientation. We saw those in 6.0 beta also .. going to find the reason and the bug number
Comment 9 Florian Nadge 2011-05-07 05:29:36 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
This field is the basis of the errata or release note for this bug. It can also be used for change logs.

The Technical Note template, known as CCFR, is as follows:

Cause
    What actions or circumstances cause this bug to present.
Consequence
    What happens when the bug presents.
Fix
    What was done to fix the bug.
Comment 10 errata-xmlrpc 2011-05-19 09:11:24 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-0594.html

Note You need to log in before you can comment on or make changes to this bug.