Bug 63330 - Files don't show up with ls (or find, cp)
Files don't show up with ls (or find, cp)
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: fileutils (Show other bugs)
7.2
i386 Linux
medium Severity high
: ---
: ---
Assigned To: wdovlrrw
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-04-12 13:07 EDT by Alain Picard
Modified: 2007-04-18 12:41 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-12 13:17:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alain Picard 2002-04-12 13:07:48 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020326

Description of problem:
As root, Running ls -al doesn't return all files in a directory.
Only show ., .. and a README file that I added afterward.

There are 12 other files that are not shown. They show up with tree, evolution
or gmc.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Log as root (as a precaution)
2./bin/ls -al  (again to make sure that the alias doesn't interfere)
	

Actual Results:  [apicard@master configs]$ /bin/ls -al
total 460
drwxr-xr-x    2 root     root         4096 Apr 12 11:47 .
drwxr-xr-x   16 root     root         4096 Apr 12 11:49 ..
-rw-r--r--    1 root     root        14242 Apr 12 11:47 README

Results with tree:
[apicard@master configs]$ tree
.
|-- README
|-- kernel-2.4.9-athlon-smp (copy).config
|-- kernel-2.4.9-athlon-smp.config
|-- kernel-2.4.9-athlon.config
|-- kernel-2.4.9-i386-BOOT.config
|-- kernel-2.4.9-i386-smp.config
|-- kernel-2.4.9-i386.config
|-- kernel-2.4.9-i586-smp.config
|-- kernel-2.4.9-i586.config
|-- kernel-2.4.9-i686-debug.config
|-- kernel-2.4.9-i686-enterprise.config
|-- kernel-2.4.9-i686-smp.config
`-- kernel-2.4.9-i686.config



Expected Results:  To see all files 

Additional info:

With evolution, looked at file properties and they are -rw-r--r-- or 644.
Comment 1 Alain Picard 2002-04-12 13:14:53 EDT
listing sent was cut/paste as user other than root, results were the same for root.
Also problem appears only here but had appear elsewhere a few days ago.
Comment 2 Bernhard Rosenkraenzer 2002-04-12 13:17:51 EDT
This looks like you've been rooted and someone installed a 
fake fileutils. 
Please verify the integrity of fileutils on your installation 
using rpm -V fileutils. 
Comment 3 Alain Picard 2002-04-18 10:06:03 EDT
You were right. I had been rooted.

Note You need to log in before you can comment on or make changes to this bug.