Bug 633342 - [6.1 FEAT] Valgrind System z support - installer part
[6.1 FEAT] Valgrind System z support - installer part
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: releng (Show other bugs)
6.1
s390x All
high Severity high
: beta
: 6.1
Assigned To: Dennis Gregorovic
Release Test Team
: FutureFeature
Depends On:
Blocks: 633878 538808 580566
  Show dependency treegraph
 
Reported: 2010-09-13 11:42 EDT by IBM Bug Proxy
Modified: 2011-04-07 14:50 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-12-17 14:50:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
IBM Linux Technology Center 67029 None None None Never

  None (edit)
Description IBM Bug Proxy 2010-09-13 11:42:17 EDT
1. Feature Overview:
Feature Id: [67029]
a. Name of Feature: [6.1 FEAT] Valgrind System z support - installer part
b. Feature Description
This feature requests to add Valgrind package support to Linux on System z installations.  The
package upgrade (3.6.0) and patch on top to have the System z backend is requested and tracked in a
different feature.


2. Feature Details:
Sponsor: LTC zSeries BOE
Architectures:
  zSeries - 64 native, 

Arch Specificity: both
Affects Kernel Modules: Field does not exist
Delivery Mechanism: LDP Deliverable
Category: other
Request Type: Code Development Support from Distributor
d. Upstream Acceptance: Field does not exist
Sponsor Priority P1
f. Severity: ship issue
IBM Confidential: No
Code Contribution: 3rd party code
g. Component Version Target:
---

3. Business Case
Valgrind has proven to be a valuable tool debugging user-space memory management problems on x86 and
PPC platforms.  Serveral customers have requested to have this tool on System z as well.  Besides
the capabilities to debug memory problems other plugins (cachegrind) enable to analyze the cache
accesss patterns of applications which turned out to be a key issue in order to get the best
performance on z10 machines.

4. Primary contact at Red Hat:
John Jarvis
jjarvis@redhat.com

5. Primary contacts at Partner:
Project Management Contact:
Hans-Georg Markgraf, mgrf@de.ibm.com

Technical contact(s):
Gonzalo Muelas Serrano, gmuelas@de.ibm.com
Comment 2 IBM Bug Proxy 2010-10-04 12:10:14 EDT
------- Comment From rsisk@us.ibm.com 2010-10-04 11:32 EDT-------
Code Upstream Status: In Progress
Comment 7 IBM Bug Proxy 2010-12-17 03:23:02 EST
------- Comment From mgrf@de.ibm.com 2010-12-17 03:13 EDT-------
The installer part of the Valgrind feature requests to add Valgrind to the list of  packages in installer to have Valgrind available as installable option.
Comment 8 Dennis Gregorovic 2010-12-17 13:49:48 EST
This would be a package change, not a comps change.  In valgrind.spec we have:

    ExclusiveArch: %{ix86} x86_64 ppc ppc64

I don't know why the package isn't built on s390x.  Jakub should have the
answer.
Comment 9 Jakub Jelinek 2010-12-17 14:10:58 EST
For the package change there is another bug open already.  No idea why exactly this has been filed, perhaps just in case something in comps needs to be adjusted too.
Comment 10 Dennis Gregorovic 2010-12-17 14:30:18 EST
Ah, I missed bug #633878.

No comps changes are needed.  valgrind is already in the 'debugging' group, so once there is an s390x build then the package will get pulled into the s390x tree and will be selectable through the installer.

Any objections to closing the bug?
Comment 11 John Jarvis 2010-12-17 14:35:39 EST
Do we need a separate BZ to track the request to build Valgrind for s390x or is that already covered in another BZ?
Comment 12 Dennis Gregorovic 2010-12-17 14:40:19 EST
bug #632354 covers the request to build valgrind on s390x.
Comment 13 John Jarvis 2010-12-17 14:47:26 EST
Okay, I think in that case we can close this one.
Comment 14 John Jarvis 2010-12-17 14:50:18 EST
Closing as NOTABUG since https://bugzilla.redhat.com/show_bug.cgi?id=632354 will cover this.
Comment 15 IBM Bug Proxy 2011-04-05 07:20:46 EDT
------- Comment From mgrf@de.ibm.com 2011-04-05 07:19 EDT-------
This is verified on R 6.1 snapshots - set to verified   Thx

Note You need to log in before you can comment on or make changes to this bug.