Bug 633356 - [6.1 FEAT] Enhance cio_ignore usage in scripts using new handler for pending work - initscripts part
[6.1 FEAT] Enhance cio_ignore usage in scripts using new handler for pending ...
Status: CLOSED DUPLICATE of bug 631527
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: s390utils (Show other bugs)
6.1
s390x All
medium Severity medium
: beta
: 6.1
Assigned To: Dan Horák
qe-baseos-daemons
: FutureFeature, Reopened
Depends On:
Blocks: 633862 538808 580566 633469
  Show dependency treegraph
 
Reported: 2010-09-13 12:23 EDT by IBM Bug Proxy
Modified: 2010-11-30 15:14 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-30 15:14:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
IBM Linux Technology Center 67038 None None None Never

  None (edit)
Description IBM Bug Proxy 2010-09-13 12:23:04 EDT
1. Feature Overview:
Feature Id: [67038]
a. Name of Feature: [6.1 FEAT] Enhance cio_ignore usage in scripts using new handler for pending
work - initscripts part
b. Feature Description
This feature requests to enhance the cio_ignore usuage in initscripts by taking advantage of the new
cio_ignore handler to wait for cio pending work.


2. Feature Details:
Sponsor: LTC zSeries BOE
Architectures:
  zSeries - 64 native, 

Arch Specificity: purely arch specific code
Affects Kernel Modules: Field does not exist
Delivery Mechanism: LDP Deliverable
Category: other
Request Type: Code Development Support from Distributor
d. Upstream Acceptance: Field does not exist
Sponsor Priority P1
f. Severity: ship issue
IBM Confidential: No
Code Contribution: 3rd party code
g. Component Version Target:
---

3. Business Case
This feature will avoid running into possible race condition, making the code more stable. 
Resulting on less service cost and better customer satisfation.

4. Primary contact at Red Hat:
John Jarvis
jjarvis@redhat.com

5. Primary contacts at Partner:
Project Management Contact:
Hans-Georg Markgraf, mgrf@de.ibm.com

Technical contact(s):
Gonzalo Muelas Serrano, gmuelas@de.ibm.com
Comment 2 Bill Nottingham 2010-09-13 14:14:26 EDT
initscripts do not touch cio_ignore.
Comment 3 Gonzalo Muelas Serrano 2010-09-14 06:21:18 EDT
Hello,
the changes needed to implement this feature are to use the kernel
infrastructure (provided by RH Bug 631517) and the tool (provided by RH Bug
631527) in the scripts when booting the system to solve the issues workarounded with timeouts in RHEL 6.0. For more deatils, please read RH Bug 533494 comments #15 through #35, and get in contact with Dan Horak.

If the boot process just call some scripts done by Dan Horak, then is fine with me to reassign it to Dan Horak.
Comment 4 Steffen Maier 2010-09-14 08:41:18 EDT
This one is a follow-up on
RH Bug 561339 - [LTC 6.0 FEAT] 201085: unmask and wait for devices, initscripts part
which was originally created for initscripts but ended up in s390utils being triggered by an upstart event early during boot. Sorry for the confusion.

A new kernel interface to reliably block until dynamic free of devices from cio_ignore helps removing no longer necessary waiting loop code from device_cio_free and thus improves maintenance of this s390utils tool.

In order not to loose this part of the feature, reopening and reassigning to s390utils.
Comment 5 IBM Bug Proxy 2010-10-04 12:35:24 EDT
------- Comment From rsisk@us.ibm.com 2010-10-04 10:42 EDT-------
Code Upstream Status: No Code Required
Comment 8 IBM Bug Proxy 2010-11-30 05:11:19 EST
------- Comment From mgrf@de.ibm.com 2010-11-30 05:05 EDT-------
Close this feature request as duplicate
to   66875 - RHBZ 631527 -  [6.1 FEAT] Provide userspace handle to wait for cio
pending work - userspace

The functionality could be implemented into s390tools (s390utils) only and get referred to during install and boot.
The calls from installer and scripts already exist with RHEL6  (6.0 FEAT cio_ignore...)  feature request.
.
So nothing to implement for initscripts anymore.

*** This bug has been marked as a duplicate of bug 66875 ***
Comment 9 John Jarvis 2010-11-30 15:14:33 EST

*** This bug has been marked as a duplicate of bug 631527 ***

Note You need to log in before you can comment on or make changes to this bug.