Bug 63341 - "Show:" entries not translated in dateconfig
"Show:" entries not translated in dateconfig
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: dateconfig (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
:
: 63343 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-04-12 14:52 EDT by Christian Rose
Modified: 2008-05-01 11:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-06-19 09:28:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot showing untranslated entry in "Show:" widget (64.76 KB, image/png)
2002-04-12 14:54 EDT, Christian Rose
no flags Details

  None (edit)
Description Christian Rose 2002-04-12 14:52:12 EDT
Tested with beta4 and LC_ALL="sv_SE" and LANG="sv_SE" and all RHN updates as of
a few hours ago.

When I run dateconfig, I get the tool translated into Swedish.
However the entries in the "Show:" widget are not translated into Swedish.

Please see the attached screen shot.
Comment 1 Christian Rose 2002-04-12 14:54:16 EDT
Created attachment 53670 [details]
Screenshot showing untranslated entry in "Show:" widget
Comment 2 Brent Fox 2002-04-12 15:59:46 EDT
*** Bug 63343 has been marked as a duplicate of this bug. ***
Comment 3 Brent Fox 2002-04-12 18:53:32 EDT
Should be fixed in dateconfig-0.7.5-5.
Comment 4 Brent Fox 2002-04-12 18:54:02 EDT
That is, it should be fixed for the languages that I have translations for.  The
others I can't do anything about.
Comment 5 Christian Rose 2002-04-15 08:16:02 EDT
Will this change get pushed to the i18n server so that translators can fix their
translations? The current pot file for dateconfig in i18n.redhat.com CVS has a
last-modified date of "Thu Aug 30 2001".
Comment 6 Brent Fox 2002-04-16 11:08:05 EDT
At this point, the translators wouldn't have time to change it anyway.

Here's what happened.  Initially, we thought that gnome-python2-canvas would be
ready in time, so I ported dateconfig to python2/gtk2/gnome-python2-canvas. 
However, pretty late in the cycle it was determined that gnome-python2-canvas
wouldn't be ready in time, so I basically had to revert to the dateconfig that
was shipped in 7.2 and backport the bugfeatures from the gtk2 tree.  Besides,
all the major langs will have the translations.
Comment 7 Christian Rose 2002-04-19 05:29:18 EDT
> At this point, the translators wouldn't have time to change it anyway.

Unless you're planning the final release within hours and then plan to
discontinue development, I'm not sure what the reason is behind this overly
pessimistic thinking. rhn-applet, rhn_register and up2date modules were pushed
to the i18n server fairly late and just a few days after that many non-core
languages hade complete translations of them. Not to say that this is an ideal
situation, but that you can be surprised at what some translators can manage.


> Besides, all the major langs will have the translations.

So the rest can be ignored and not even given the chance?
Comment 8 Brent Fox 2002-04-19 09:08:00 EDT
> Unless you're planning the final release within hours and then plan to
discontinue development, I'm not sure what the reason is behind this overly
pessimistic thinking.

> So the rest can be ignored and not even given the chance?

I'm not being negative and I'm not intentionally slighting other languages. 
When I said that there wasn't time to change it, that's what I meant.  Not being
harsh or anything, but there is _no_ more time.
Comment 9 Christian Rose 2002-04-24 20:51:06 EDT
Is there time now?
I still suspect there will be another release of dateconfig in the history of
mankind, whether it be as an update to the next Red Hat Linux release or in the
next Red Hat Linux release after that or even later, but the sooner translators
get to translate dateconfig, the better the situation will be when it's time to
release dateconfig the next time. That's my whole point.
Comment 10 Brent Fox 2002-04-25 10:25:36 EDT
Yes, there is time now.
Comment 11 Brent Fox 2002-04-25 11:05:47 EDT
However, these particular strings will not have to be translated in future
versions of dateconfig.  The timezone selector screen uses the same code that
anaconda does.  The next version of anaconda will use a Python version of the
gnome-map instead of the C one.  One difference is that the map is made a little
larger, therefore the need to zoom in on a part of the map is no longer
necessary.  Therefore, the "View" label and the section tags like "North
America" and "Pacific Rim" won't be on the screen anymore.
Comment 12 Christian Rose 2002-04-25 19:36:51 EDT
Ok, thanks for the information.
Comment 13 Brent Fox 2002-06-27 17:20:31 EDT
Ok.  I'm closing since the string in question is no longer in the interface.  I
just updated the pot file in CVS for the latest UI changes, so everything should
be marked for translations now unless I missed something.  If I have missed
something, please open a new bug report.  Thanks for your help.

Note You need to log in before you can comment on or make changes to this bug.