Bug 63350 - [RFE] allow download of src.rpm's for already installed rpm's
[RFE] allow download of src.rpm's for already installed rpm's
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: up2date (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
Jay Turner
: FutureFeature
: 65105 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-04-12 16:50 EDT by Jef Spaleta
Modified: 2015-01-07 18:55 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-07-28 21:43:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jef Spaleta 2002-04-12 16:50:51 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.0 (X11; Linux i686; U;) Gecko/20020314

Description of problem:
I would like to use up2date to download src.rpm for rpm's I already have
installed (say for recompiling for cpu optimizations).  Right now you can only
download src.rpm's when you download a binary.  It would be nice to be able to
get the src for any package whether its installed or not. 

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:

	

Additional info:
Being able to specify a different download location for src and binary packages
would be a plus...but I'd more than settle with just being able to use up2date
to get src for already installed packages.
Comment 1 Bob Cochran 2002-04-12 18:23:15 EDT
In addition, I'd like the ability to select source RPMs for downloading from a
list of RPMs (in case I need to download a large number of binaries and only
want 1 or 2 source modules.) Thank you very much for your help with this.
Comment 2 Adrian Likins 2002-05-17 14:45:27 EDT
*** Bug 65105 has been marked as a duplicate of this bug. ***
Comment 3 James Manning 2002-05-17 15:24:53 EDT
cc and update ver so it doesn't drop off any radar screens for being against a beta
Comment 4 Adrian Likins 2003-08-06 18:19:00 EDT
this is now available circa version 3.1.40 or so. 

Note You need to log in before you can comment on or make changes to this bug.