Bug 63364 - Different version of sensors.h than in kernel-source
Different version of sensors.h than in kernel-source
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: glibc-kernheaders (Show other bugs)
9
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-04-12 18:38 EDT by RLX Technologies
Modified: 2015-01-04 17:01 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-27 17:58:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description RLX Technologies 2002-04-12 18:38:16 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.0 (X11; Linux i686; U;) Gecko/20020326

Description of problem:
The /usr/include/linux/sensors.h header file from glibc-kernheaders is not the
same version as the one in the kernel package.  The version in the kernel is
from lm_sensors 2.6.1.  This bug is present in beta4.

Version-Release number of selected component (if applicable):
kernel-2.4.18-0.4
glibc-kernheaders-2.4-7.11

How reproducible:
Always

Steps to Reproduce:
diff -u /usr/include/linux/sensors.h /usr/src/linux/include/linux/sensors.h
Comment 1 Arjan van de Ven 2002-04-13 02:57:42 EDT
Ok how is this a bug ?
The kernel ABI is stable and doesn't change much so why is it a big deal that
the glibc headers are different from the kernel-internal ones ? As long as both
describe the proper ABI./...
Comment 2 RLX Technologies 2002-04-17 10:24:05 EDT
Perhaps I don't understand the purpose of having the sensors/i2c header files in
the glibc-kernheaders package at all??

The issue that I see is that some of the #define values and variable names are
different in the two header files.  Therefore, since the sensors modules in 7.3
have been compiled against the header file in
/usr/src/linux/include/linux/sensors.h anything compiled using
/usr/include/linux/sensors.h would not have the correct values for these #defines.  

What is the criteria for determining what version of kernel headers to include
in the glibc-kernheaders package?  Why wouldn't they be the same headers as the
shipped kernel?
Comment 3 Arjan van de Ven 2002-04-17 10:33:49 EDT
the glibc-kernheaders package is the package glibc and libraries are compiled
against..... nothing to do with the kernel at all.

Note You need to log in before you can comment on or make changes to this bug.