Bug 63366 - XFree86 is installed when not selected
XFree86 is installed when not selected
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: anaconda (Show other bugs)
skipjack-beta2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Brock Organ
:
Depends On:
Blocks: 61590
  Show dependency treegraph
 
Reported: 2002-04-12 19:47 EDT by RLX Technologies
Modified: 2007-04-18 12:41 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-15 18:16:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description RLX Technologies 2002-04-12 19:47:18 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.0 (X11; Linux i686; U;) Gecko/20020326

Description of problem:
XFree86 is installed when it has been unchecked after choosing "Server" install.
 This issue is present in 7.2.93 (Skipjack).

How reproducible:
Always

Steps to Reproduce:
1. Choose "Server" during install
2. Uncheck "Classic X Window System"
3. Uncheck "Gnome"
4. Uncheck "KDE"
5. Proceed with install

Actual Results:  After install the system has the following packages installed:
XFree86-base-fonts-4.2.0-6.52
XFree86-twm-4.2.0-6.52
XFree86-libs-4.2.0-6.52
XFree86-font-utils-4.2.0-6.52
XFree86-devel-4.2.0-6.52
XFree86-75dpi-fonts-4.2.0-6.52
XFree86-4.2.0-6.52
XFree86-ISO8859-15-100dpi-fonts-4.2.0-6.52
XFree86-tools-4.2.0-6.52
XFree86-xfs-4.2.0-6.52
XFree86-100dpi-fonts-4.2.0-6.52
XFree86-xdm-4.2.0-6.52
XFree86-ISO8859-15-75dpi-fonts-4.2.0-6.52

Expected Results:  No X packages.
Comment 1 Alexei Podtelezhnikov 2002-04-12 23:14:01 EDT
Just go ahead and run:
rpm -q --whatrequires XFree86-base-fonts (and all the other packages 
you don't want from your list). This way you should be able to locate 
what else to "uncheck"(unistall) to prevent them from pulling in.
"man rpm" for more details.
Comment 2 Bill Nottingham 2002-04-14 23:29:42 EDT
What other components did you have selected?
Comment 3 RLX Technologies 2002-04-15 16:33:47 EDT
I did not select "Choose individual packages" I only picked from the main list
after choosing "Server" class install.  I did not pick Gnome or KDE or any other
X related package group.  I selected all other non X related package groups. 
Again, this is from the "package groups" menu not the individual package
selection menu.

Doing this in 7.2 results in xfs and XFree86-libs being the only packages installed.

Is it now nescessary to go into individual packages selection in order to
prevent  the other XFree86 packages from being installed? 
Comment 4 Jeremy Katz 2002-04-15 17:45:33 EDT
Due to the Emacs comp group pulling in X Window System.  Fixed in CVS
Comment 5 Jay Turner 2002-04-16 12:14:46 EDT
Indeed.  Confirmed fixed with the re0416.1 tree.

Note You need to log in before you can comment on or make changes to this bug.