Bug 63381 - Files tarred to an HP Travan 5G can not be restored
Files tarred to an HP Travan 5G can not be restored
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.2
i586 Linux
medium Severity medium
: ---
: ---
Assigned To: Pete Zaitcev
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-04-13 01:39 EDT by Need Real Name
Modified: 2007-04-18 12:41 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-05-21 18:17:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg after "tar c" (10.34 KB, text/plain)
2002-04-17 13:48 EDT, Pete Zaitcev
no flags Details

  None (edit)
Description Need Real Name 2002-04-13 01:39:50 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; Q312461)

Description of problem:
Tar seems to work ok when writing (though this is uncofirmed).  
tar cvf /dev/ht0 ./testdirectory  shows files being written, and tape drive 
makes noise.  
tar xvf /dev/ht0 makes noise, but no files are shown to be restored and none 
are restored.
I next pulled out the tape drive and put in a seagate travan 20G, which worked 
as desired.  i.e. just the HP had trouble.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.create tar file on HP travan 5G (internal eide)
2.attempt to restore files
3.
	

Actual Results:  nothing was resotred

Expected Results:  the tarred files should have been restored

Additional info:

The HP tape drive works properly under windows nt and xp.
Comment 1 Bernhard Rosenkraenzer 2002-04-15 12:05:26 EDT
Sounds like a driver problem...
Comment 2 Pete Zaitcev 2002-04-15 15:40:47 EDT
Please provide /proc/version and the dmesg output.
Please attach dmesg output as attachement and
DO NOT DROP IT INTO THE COMMENTS BOX.
Comment 3 Pete Zaitcev 2002-04-17 13:48:33 EDT
Created attachment 54204 [details]
dmesg after "tar c"
Comment 4 Pete Zaitcev 2002-04-17 13:50:02 EDT
I suggest using ide-scsi instead of ide-tape.
Comment 5 Need Real Name 2002-04-17 20:50:11 EDT
Following your suggestion, I tried ide-scsi rather than ide-tape, and the tape drive now works as desired as /dev/st0.

Specifically, I added to my grub.conf:

append="hdd=ide-scsi"

and added to my /etc/rc.d/rc.local:

modprobe ide-scsi 

then restared linux.  Obviously, this is more of a work-around than a bug-fix.  

Thank you very much for the suggestion.
Comment 6 Need Real Name 2002-05-21 18:17:53 EDT
I recently upgraded to redhat 7.3.  The ide-scsi solution no longer worked (seems to be a problem with ide-scsi), but the present bug regarding the ide HP tape-drive 
appears to be resolved, i.e. `` tar cvf /dev/ht0 directory''  now works as desired.
Comment 7 Doug Ledford 2002-05-23 20:04:35 EDT
Thanks for the confirmation that 7.3 made the tape drive work properly.  I'm
closing this bug out as fixed in current release.

Note You need to log in before you can comment on or make changes to this bug.