This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 633870 - [kn_IN] Shortcut key conflict in localized message, while English as Different shortcut
[kn_IN] Shortcut key conflict in localized message, while English as Differen...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: gnome-panel (Show other bugs)
6.1
All Linux
low Severity medium
: rc
: ---
Assigned To: Ray Strode [halfline]
desktop-bugs@redhat.com
: Translation
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-09-14 10:59 EDT by A S Alam
Modified: 2013-07-02 21:05 EDT (History)
4 users (show)

See Also:
Fixed In Version: gnome-panel-2.30.2-6.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-05-19 10:12:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
A patch to fix Kannada (kn) translation shortcut issue for gnome-panel (445 bytes, patch)
2010-12-23 03:47 EST, Ankit Patel
no flags Details | Diff

  None (edit)
Description A S Alam 2010-09-14 10:59:19 EDT
Description of problem:
when right click on Date/Time in Gnome Panel. Check Shortcut key with Copy Date and Copy Time.

Version-Release number of selected component (if applicable):
gnome-panel-2.30.2-5.el6.x86_64

How reproducible:
Everytime

Steps to Reproduce:
1. Login to kn_IN Desktop
2. Right click on Date
3. Check Shortcut "D" for Copy Time and Copy Date string in Right Click Menu

  
Actual results:
Copy Date and Copy Time, both strings has Alt+D shortcut

Expected results:
Copy Time need to be Alt+C Shortcut as original string

Additional info:
http://l10n.gnome.org/POT/gnome-panel.gnome-2-28/gnome-panel.gnome-2-28.kn.po

#: ../applets/clock/GNOME_ClockApplet.xml.h:3
msgid "Copy _Time"
msgstr "ಸಮಯವನ್ನು ಕಾಪಿ ಮಾಡು(_D)"
Comment 2 Ankit Patel 2010-09-15 01:03:51 EDT
Hi Shankar,

Can you please fix the reported translation issue both upstream and downstream?

Thanks!
Ankit
Comment 4 Ankit Patel 2010-09-15 04:57:11 EDT
(In reply to comment #3)
> Fixed the shortcut issue in both upstream and downstream.
> 
> 2-30:
> http://git.gnome.org/browse/gnome-panel/commit/?h=gnome-2-30&id=2eed9ac837b7f1449dac1819546142cb852f649e
> 
> 2-28:
> http://git.gnome.org/browse/gnome-panel/commit/?h=gnome-2-28&id=8fff63bd16a0a61010732a2bd7012949e3c76d85

Thanks Shankar.

I will provide a patch for the fix submitted by you.

Till then I will own this bug.

Thanks!
Ankit
Comment 5 Ankit Patel 2010-11-29 23:19:25 EST
Localization members would provide fix for translations. Reassigning bug back to the owner of the component to take care of the dev-ack.

Thanks!
Ankit
Comment 6 Ray Strode [halfline] 2010-11-30 13:46:18 EST
I have no problem with gnome-panel getting updated for this fix.  If you have a patch ready to got, Ankit, feel free to commit it when possible.
Comment 7 Ankit Patel 2010-12-23 03:47:01 EST
Created attachment 470389 [details]
A patch to fix Kannada (kn) translation shortcut issue for gnome-panel

Since all acks are approved and ray strode (owner of the component) granted me the permission to build the package, I am making a new build for gnome-panel (gnome-panel-2.30.2-6.el6) that should fix the reported issue.
Comment 10 errata-xmlrpc 2011-05-19 10:12:38 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-0710.html

Note You need to log in before you can comment on or make changes to this bug.