Bug 63416 - no entry in /etc/ld.so.conf for wine so programs fail to run
no entry in /etc/ld.so.conf for wine so programs fail to run
Status: CLOSED CURRENTRELEASE
Product: Red Hat Public Beta
Classification: Retired
Component: wine (Show other bugs)
skipjack-beta2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: wdovlrrw
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-04-13 10:29 EDT by Need Real Name
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-05-08 21:26:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-04-13 10:29:09 EDT
Description of Problem:  Installation of wine rpm fails to insert 
/usr/lib/wine into /etc/ld.so.conf, so windows applications fail.
Adding entry manually and running ldconfig -v allows programs to
run.

Version-Release number of selected component (if applicable):
wine-20020327-1

How Reproducible:
Yes.

Steps to Reproduce:
1. rpm -e wine
2. manually delete /usr/lib/wine entry in ld.so.conf
3. rpm -ivh wine-wine-20020327-1.i386.rpm
4. Note no entry in ld.so.conf

Actual Results:


Expected Results:


Additional Information:
Comment 1 Bernhard Rosenkraenzer 2002-04-15 12:30:40 EDT
The package has the following: 
 
%post 
if ! grep -q "^/usr/lib/wine$" /etc/ld.so.conf; then 
        echo "/usr/lib/wine" >>/etc/ld.so.conf 
fi 
/sbin/ldconfig 
/sbin/chkconfig --add wine 
/sbin/chkconfig --level 2345 wine on 
/sbin/service wine start &>/dev/null || : 
 
 
So it should be ok. 
Did you upgrade from an older version?
Comment 2 Richard Smith 2002-04-23 17:12:24 EDT
I have seen the same thing.  I upgraded to Skipjack-beta-2 from RedHat 7.2, on
which I had a fully functional wine installation.

I also found that the 'chkconfig --add' had not been run and that wine had not
been enabled for runlevels 2345 (ie none of the '%post' script seems to have
been executed):

[root@holly root]# chkconfig --list wine
service wine supports chkconfig, but is not registered (run 'chkconfig --add wine')
[root@holly root]# chkconfig --add wine
[root@holly root]# chkconfig --list wine
wine            0:off   1:off   2:off   3:on    4:off   5:on    6:off
[root@holly root]# chkconfig --level 2345 wine on
[root@holly root]# chkconfig --list wine
wine            0:off   1:off   2:on    3:on    4:on    5:on    6:off
[root@holly root]# /sbin/service wine start
Registering binary handler for Windows applications

Comment 3 keithu@parl.clemson.edu 2002-05-08 21:26:46 EDT
I just did an upgrade for an RH7.2 box directly to 7.3. I had a working wine
config and yet I had the same problem after the upgrade.  Fixed /etc/ld.so.conf
and suddenly it worked.
Comment 4 Bernhard Rosenkraenzer 2002-05-19 14:08:00 EDT
The problem is in the old package (its %postun script removed the ld.so.conf 
entry even on an upgrade). 
 
Workarounds: 
- Update by removing the old package, then installing the new one 
- Install the new package twice (rpm -U wine* ; rpm -U --force wine*) 
 
There's nothing else that can be done about it because the problem isn't 
caused by any current package. 
 
Closing CURRENTRELEASE because the package in 7.3 does not have this problem 
(meaning you can update from 7.3 to anything later without running into it). 

Note You need to log in before you can comment on or make changes to this bug.