Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 63419 - Foomatic refuses to print ascii from commandline
Foomatic refuses to print ascii from commandline
Status: CLOSED DUPLICATE of bug 59481
Product: Red Hat Linux
Classification: Retired
Component: printconf (Show other bugs)
7.2
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-04-13 10:54 EDT by Jesse Keating
Modified: 2008-05-01 11:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-25 13:02:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Requested file for debugging purposes (425 bytes, application/octet-stream)
2002-04-25 11:26 EDT, Jesse Keating
no flags Details

  None (edit)
Description Jesse Keating 2002-04-13 10:54:14 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020408

Description of problem:
Foomatic / lpr will not print an ascii file to the printer either through the
command line or through the printconf TUI tool.  I get the following message in
/var/spool/lpd/<printername>/lpq.0:

 Status: IF filter 'mf_wrapper' filter msg -
'/usr/share/printconf/util/printconf_mfomatic.pl: running: gs -q -dBATCH -dSAFER
-dQUIET -dNOPAUSE -sDEVICE=bjc600 -sOutputFile=- -' at 00:16:14.646
 Status: IF filter 'mf_wrapper' filter msg -
'/usr/share/printconf/util/printconf_mfomatic.pl: ascii job.  wtf!  we don't do
ascii in mfomatic' at 00:16:14.646
 Status: IF filter 'mf_wrapper' filter msg - 'we don't do ascii in mfomatic! at
/usr/share/printconf/util/printconf_mfomatic.pl line 407.' at 00:16:14.646
 Status: IF filter 'mf_wrapper' filter exit status 'UNKNOWN STATUS '255'' at
00:16:14.654
 Status: printing finished at 00:16:14.655
 Status: accounting at end at 00:16:14.655
 Status: finished 'poo@anakin+829', status 'UNKNOWN STATUS '255'' at 00:16:14.655
 Status: subserver pid 23831 exit status 'UNKNOWN STATUS '255'' at 00:16:14.656
 Status: job 'cfA829anakin.loki.net' error 'aborting operations' at 00:16:14.656
 Status: removing job 'cfA829anakin.loki.net' - ABORT at 00:16:14.657

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Run 'setup' and select the printconf tool, setup Cannon BJC 3000 with the
bjc6000 driver set.
2. Create a text file, only ascii text, named foo.txt
3. lpr foo.txt, job gets aborted.
	

Actual Results:   Status: IF filter 'mf_wrapper' filter msg -
'/usr/share/printconf/util/printconf_mfomatic.pl: running: gs -q -dBATCH -dSAFER
-dQUIET -dNOPAUSE -sDEVICE=bjc600 -sOutputFile=- -' at 00:16:14.646
 Status: IF filter 'mf_wrapper' filter msg -
'/usr/share/printconf/util/printconf_mfomatic.pl: ascii job.  wtf!  we don't do
ascii in mfomatic' at 00:16:14.646
 Status: IF filter 'mf_wrapper' filter msg - 'we don't do ascii in mfomatic! at
/usr/share/printconf/util/printconf_mfomatic.pl line 407.' at 00:16:14.646
 Status: IF filter 'mf_wrapper' filter exit status 'UNKNOWN STATUS '255'' at
00:16:14.654
 Status: printing finished at 00:16:14.655
 Status: accounting at end at 00:16:14.655
 Status: finished 'poo@anakin+829', status 'UNKNOWN STATUS '255'' at 00:16:14.655
 Status: subserver pid 23831 exit status 'UNKNOWN STATUS '255'' at 00:16:14.656
 Status: job 'cfA829anakin.loki.net' error 'aborting operations' at 00:16:14.656
 Status: removing job 'cfA829anakin.loki.net' - ABORT at 00:16:14.657

Expected Results:  A successful printing of an ascii text file.

Additional info:

I get the same message when trying to test print an ascii page from the
printconf TUI.  The postscript test page prints just fine, and since the printer
is shared out through samba, remote win32 clients can print all day long without
issues.
Comment 1 Tim Waugh 2002-04-25 07:08:32 EDT
I don't think you have applied all the updates.  Does this problem still occur 
after you have applied the updates (you can use up2date for that)?
Comment 2 Jesse Keating 2002-04-25 10:33:48 EDT
Yes, I am fully updated, aside from the 'print-conf' package.  When I update the
print-conf package, and try to configure a printer, nothing ever gets written to
/var/spool/lp, thus I am unable to print ANYthing.

foomatic-1.1-0.20011218.3
printconf-0.3.44-1

I am using those versions.
Comment 3 Tim Waugh 2002-04-25 10:37:50 EDT
You need to update printconf.  If there are other problems with the updated  
printconf version, let's look at them; but problems with 0.3.44-1 aren't going  
to get fixed if they are already fixed in the update.  
 
So: what goes wrong with the newer printconf?
Comment 4 Jesse Keating 2002-04-25 10:44:33 EDT
It is pretty simple.  Run the printconf tui, configure a printer, save it, cd to
/var/spool/lp, and it's empty.  Try again, fire up printconf, configure again
(as there is nothing there), this time try to test it, which involves a save
first, nothing.  It gets an error trying to print (due to the fact that there is
no files in /var/spool/lp).

This was effecting me a month or so ago, so if there was a recent update to
printconf, I will try.  It was my understanding though, that printconf was just
the tool to configure the printer.  The rest of the magic was done by the other
packages.
Comment 5 Tim Waugh 2002-04-25 10:48:14 EDT
Well, there is no directory /var/spool/lp on my set-up; do you mean 
/var/spool/lpd? 
 
This is working for me and plenty of other people, so the more specific you 
can be about what you are doing, the better. 
 
The /var/spool/lpd directory is provided by the 'filesystem' package.  Did you 
delete that directory?  Use 'rpm --verify filesystem printconf foomatic' to 
find out what things are wrong with the installation.
Comment 6 Jesse Keating 2002-04-25 10:55:15 EDT
Sorry, it was /var/spool/lpd  not lp.

Anyway, I just tried again, with the newer printconf, no such luck.  Removed the
current printer, configured a new one (exactly the same), tried to test, and got
the message of "Error Could not print the page"  or something to that effect. 
Exited, and /var/spool/lpd is once again empty.  If I rpm -e that version of
printconf, and install the older version (original with 7.2), configure and test
a postscript page, it works just fine.

Oddly enough, I can print ascii pages from a win32 box, through samba (the
printer is shared).  If it helps, this is a Cannon BJC3000 using the 6000
driver, default options.
Comment 7 Tim Waugh 2002-04-25 10:59:24 EDT
Please stick with the newer printconf, so that I know exactly what's going on. 
 
Once you have upgraded printconf, please show me the output of: 
 
rpm --verify foomatic printconf filesystem 
 
Then, please add the printer as normal, and attach 
/etc/alchemist/namespace/printconf/local.adl to this report. 
 
If you see an error message anywhere along the way, please say what 
says---I'll need to know the _precise_ wording so that I can find where it 
comes from. 
 
Thanks.
Comment 8 Jesse Keating 2002-04-25 11:22:49 EDT
[root@anakin root]# rpm --verify foomatic printconf filesystem 
SM5....T c /etc/alchemist/namespace/printconf/local.adl
.......T c /etc/alchemist/switchboard/printconf.swb.adl
.......T c /etc/printcap.local

Removed old printer, added new one, and just exited, and saved it when it asked
me to save.  No errors there.  I will attach that file when I am done with this
message.

After the TUI is done, and I exit from 'setup', I cd over to /var/spool/lpd/ and
do an ls.  Here is what I get:

[root@anakin lpd]# ls -al
total 2
drwxr-xr-x    2 root     root         1024 Apr 25 08:18 .
drwxr-xr-x   10 root     root         1024 Mar  9 09:17 ..
[root@anakin lpd]# 

Nothing went there.  SO!  I fire up setup again, and go to printconf.

It shows my printer there, but when I go to test it, with a US Letter PostScript
Testpage, I get this error:

There was an error trying to print the test page.

In a ncurses window, with an OK box.

Hit OK, exit the printconf (printer still shown as there), and exit setup.  Once
again, /var/spool/lpd is empty.
Comment 9 Jesse Keating 2002-04-25 11:26:32 EDT
Created attachment 55304 [details]
Requested file for debugging purposes
Comment 10 Tim Waugh 2002-04-25 11:28:03 EDT
Thanks.  Do you have mpage installed, by any chance?  If not, please install 
it and see if that makes a difference.
Comment 11 Jesse Keating 2002-04-25 12:37:25 EDT
Ok, now I can print a test page, and a test ascii page, and I can lpr foo (foo
being an ascii file).

Thank you.  Might I suggest mpage being a dependancy of the print packages? 
Would save a bit of headache....
Comment 12 Tim Waugh 2002-04-25 13:03:18 EDT

*** This bug has been marked as a duplicate of 59481 ***
Comment 13 Jesse Keating 2002-04-25 13:06:48 EDT
I am still confused as to why printconf would not write out the configuration to
/var/spool/lpd without the mpage package installed.  Seems quite odd.  I do see
how making mpage be a dependancy would solve it, but that's kinda like a
bandaid, not a resolution.  *shrug* oh well.

Note You need to log in before you can comment on or make changes to this bug.