Bug 634204 - Runing make on fresh svn checkout modifies the checked-out sources
Runing make on fresh svn checkout modifies the checked-out sources
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: sos (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Pierre Carrier
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-09-15 10:00 EDT by Tomas Smetana
Modified: 2010-11-16 12:37 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-15 10:05:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tomas Smetana 2010-09-15 10:00:57 EDT
Description of problem:
It's difficult to review changes made to local svn checkout since the make command modifies the gettext .po files.

Version-Release number of selected component (if applicable):
sos svn checkout

How reproducible:
Always

Steps to Reproduce:
1. svn co http://svn.fedorahosted.org/svn/sos/trunk sos
2. cd sos
3. make
4. svn status | grep '^M' | wc -l
  
Actual results:
78

Expected results:
0 (since I didn't modify anything)

Additional info:
I think somebody with commit permission should run make himself and commit the updated .po files to the svn. I'm not sure modifying the files "in-situ" is a good thing since it creates difficulties reviewing one's own changes of the svn checkout.
Comment 1 Fedora Admin XMLRPC Client 2010-11-10 08:05:35 EST
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 3 Pierre Carrier 2010-11-15 10:05:11 EST
Thanks Tomas.

https://fedorahosted.org/sos/changeset/993

Note You need to log in before you can comment on or make changes to this bug.