Bug 63430 - Konqueror crashes when in browser and closing the embedded terminal (after selecting horizontal split)
Konqueror crashes when in browser and closing the embedded terminal (after se...
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: kdebase (Show other bugs)
skipjack-beta2
i386 Linux
medium Severity high
: ---
: ---
Assigned To: wdovlrrw
Ben Levenson
www.kde.org (any URL will do)
:
Depends On:
Blocks: 61901
  Show dependency treegraph
 
Reported: 2002-04-13 14:26 EDT by Peter van Egdom
Modified: 2007-04-18 12:41 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-14 23:36:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Peter van Egdom 2002-04-13 14:26:45 EDT
From Bugzilla Helper: 
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.0.0-8; Linux) 
 
Description of problem: 
When in Konqueror - having selected the terminal emulator  
(Window -> Terminal Emulation) - and going to the embedded terminal window; 
then selecting 'Split window horizontal' on the bar that separates the embedded browser 
from the embedded terminal emulator (use the right mouse button on the grey area).  
 
After this has been done, selecting 'close terminal emulation' (use the right mouse  
button on the terminal area) will crash Konqueror. 
 
 
 
Version-Release number of selected component (if applicable): 
Version     : 3.0.0                             Vendor: Red Hat, Inc. 
Release     : 6                             Build Date: wo 10 apr 2002 12:32:57 CEST 
Install date: za 13 apr 2002 16:53:52 CEST      Build Host: daffy.perf.redhat.com 
Group       : User Interface/Desktops       Source RPM: kdebase-3.0.0-6.src.rpm 
Size        : 35838945                         License: GPL 
 
 
 
 
How reproducible: 
Always 
 
Steps to Reproduce: 
1. Start konqueror, load your favourite URL. 
2. Start the embedded terminal emulator (Window -> show terminal emulation) 
2. Click on the embedded terminal window. 
3. Click with right mouse button on the gray area which separates the embedded 
   browser from the embedded terminal emulator and select 'split window 
   horizontal' 
4. (another embedded browser will load (in the middle of the main konqueror window). 
5. Close the embedded terminal emulator (right mouse button on terminal 
   emulator and select 'close terminal emulator'). 
6. Konqueror crashes. 
 
  
 
Actual Results:  Konqueror crashed. Here's the trace : 
 
(no debugging symbols found)...(no debugging symbols found)... 
(no debugging symbols found)...(no debugging symbols found)... 
(no debugging symbols found)...(no debugging symbols found)... 
(no debugging symbols found)...(no debugging symbols found)... 
(no debugging symbols found)...[New Thread 1024 (LWP 19475)] 
0x420b47f9 in wait4 () from /lib/i686/libc.so.6 
#0  0x420b47f9 in wait4 () from /lib/i686/libc.so.6 
#1  0x4213030c in __DTOR_END__ () from /lib/i686/libc.so.6 
#2  0x40ee4ca3 in waitpid () from /lib/i686/libpthread.so.0 
#3  0x406ab352 in KCrash::defaultCrashHandler () from /usr/lib/libkdecore.so.4 
#4  0x40ee2f75 in pthread_sighandler () from /lib/i686/libpthread.so.0 
#5  <signal handler called> 
 
 
Expected Results:  No crash :-) 
 
Just the embedded terminal emulator should have closed. 
 
Additional info: 
 
[peterve@localhost peterve]$ rpm -qfi /usr/bin/konqueror 
Name        : kdebase                      Relocations: (not relocateable) 
Version     : 3.0.0                             Vendor: Red Hat, Inc. 
Release     : 6                             Build Date: wo 10 apr 2002 12:32:57 CEST 
Install date: za 13 apr 2002 16:53:52 CEST      Build Host: daffy.perf.redhat.com 
Group       : User Interface/Desktops       Source RPM: kdebase-3.0.0-6.src.rpm 
Size        : 35838945                         License: GPL 
Packager    : Red Hat, Inc. <http://bugzilla.redhat.com/bugzilla> 
URL         : http://www.kde.org 
Summary     : K Desktop Environment - core files
Comment 1 Bernhard Rosenkraenzer 2002-04-15 11:12:21 EDT
Can't reproduce this with the current versions.

Note You need to log in before you can comment on or make changes to this bug.