Bug 63434 - after installing the rpm 4.0.4-7x errata rpm -e spews errors
after installing the rpm 4.0.4-7x errata rpm -e spews errors
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-04-13 17:14 EDT by Seth Vidal
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-13 17:14:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Seth Vidal 2002-04-13 17:14:02 EDT
Description of Problem:
install rpm 4.0.4-7x errata on rhl 7.1

[root@terminus /root]# rpm -e gnorpm
error: cannot open Dirnames index using db3 - No such file or directory (2)
error: cannot open Requireversion index using db3 - No such file or directory (2)
error: cannot open Provideversion index using db3 - No such file or directory (2)
error: cannot open Installtid index using db3 - No such file or directory (2)
error: cannot open Sigmd5 index using db3 - No such file or directory (2)
error: cannot open Filemd5s index using db3 - No such file or directory (2)


Version-Release number of selected component (if applicable):
rpm-4.0.4-7x

How Reproducible:
every time


Steps to Reproduce:
1. install 4.0.4-7x errata on 7.1
2.  rpm -e [any package]
3. watch the errors.


Actual Results:


Expected Results:


Additional Information:
doesn't happen on 7.2
curiously
Comment 1 Jeff Johnson 2002-04-13 17:26:03 EDT
Error is harmless. Do a --rebuilddb to create the
new indices and the message will go away.
Comment 2 Michael Johnson 2002-09-24 18:43:59 EDT
I consistently get this problem when installing a system out using an updated
RPM repository.  (kickstart install from a network share with an updated
Redhat/RPMS directory)

It seems to be an interaction with Anaconda and the new RPM-4.0.4-7x rpm.

Could the RPM rpm be overwriting the one ananconda is building?

Note You need to log in before you can comment on or make changes to this bug.