Bug 63446 - ignored updates don't translate to up2date
ignored updates don't translate to up2date
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: rhn-applet (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Veillard
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-04-13 21:30 EDT by Bill Nottingham
Modified: 2014-03-16 22:26 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-17 18:48:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Nottingham 2002-04-13 21:30:51 EDT
This may not be that easy to do, but it makes sense that if you're ignoring
updates in the applet, you don't want to install them with up2date either.
Comment 1 Chip Turner 2002-04-13 23:40:10 EDT
I can pass them on the command line or up2date can read the applet's config
file... either way, passing this off to alikins to decide if/when to put such
features in.  Once they're in, I can adapt the applet.
Comment 2 Daniel Veillard 2003-01-17 11:07:02 EST
Hum, the basic problem is that up2date is really a root process while
the applet runs as the user's. Having up2date read the user's 
.rhn-applet.conf doesn't sound safe, and the applet can't read the
system package skip list because /etc/sysconfig/rhn/up2date is rightly
protected from user's access.
  Only manual update of the user .rhn-applet.conf seems safe, unless 
some of the options of up2date can be made public in a separate config
file.
  Not sure it's worth it,

Daniel
Comment 3 Bill Nottingham 2003-01-17 15:44:36 EST
/etc/sysconfig/rhn/up2date is world readable, at least for me.
Comment 4 Daniel Veillard 2003-01-17 18:19:34 EST
I checked on 5 boxes, some I maintain, some I don't, they all have
-rw-------    1 root     root
mask for /etc/sysconfig/rhn/up2date . You can check porkchop for example !

Daniel
Comment 5 Bill Nottingham 2003-01-17 18:48:56 EST
Yeah, my box must be weird. Never Mind Then.

Note You need to log in before you can comment on or make changes to this bug.