Bug 63450 - anaconda blows up on a querry about swap file
Summary: anaconda blows up on a querry about swap file
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
(Show other bugs)
Version: 7.3
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Michael Fulbright
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-04-14 04:37 UTC by Michal Jaegermann
Modified: 2007-04-18 16:41 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-16 03:26:07 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda droppings from an attempted update (63.21 KB, text/plain)
2002-04-16 03:26 UTC, Michal Jaegermann
no flags Details

Description Michal Jaegermann 2002-04-14 04:37:33 UTC
Description of Problem:

In an attempt to correct a problem described in 63449 I attempt to
"update" unfinished installation (it is good enough to be bootable).
Anaconda insists that I need an extra swap file, which is really bogus,
of a size of 97 MBytes.  Regardless if I refuse or agree to a creation
of this file anaconda immediately blows up.

Attempts to read a floppy were presumably 'anacdump.txt' was written
show file of a size of 65570 bytes but every try to read that file
ends up with:

plain_io: Input/output error
file read: Illegal seek

Keep in mind that it is quite possible that I do NOT even have a floppy
in my machine (I do, but obviously it has some disagreements with anaconda).

Anyway, this should be trivial to recreate as anaconda throws fits
every time.

Comment 1 Jeremy Katz 2002-04-15 16:02:17 UTC
Works for me.  If you can't give at least the end of the traceback, there's not
much I can do as I can't reproduce the problem.

Comment 2 Michal Jaegermann 2002-04-15 18:27:22 UTC
I tried to get that traceback but whatever writes it makes it totally
unreadable.  The floppy on which this save was attempted is definitely
ok as some hour ago I "recycled" that floppy, after tests, to do firmware
updates on another machine and everything went without a hitch.

The whole initial installation was a "reformat and install" on two partitions
of a SCSI disk (sda7 and sda8); not an attempt to "update" something residing
there before.

Comment 3 Michal Jaegermann 2002-04-16 03:24:39 UTC
> Works for me.

I am really glad.  But it does not work for me.  Here is the backtrace
(and do not ask for hoops I had to get to make sure that it is available
and readable).

You can notice there "The installer is unable to detect the boot loader
currently in use on your system".  The system boots from another device,
it is doing just fine, and nobody asked for that detection.  Still not
a good reason to blow up.


Comment 4 Michal Jaegermann 2002-04-16 03:26:03 UTC
Created attachment 53964 [details]
anaconda droppings from an attempted update

Comment 5 Jeremy Katz 2002-04-16 06:51:13 UTC
Yep, actually caught this one earlier today.  Thanks for the traceback though. 
I just happened to catch it looking at something else, so otherwise this one
might have slipped through the cracks.

Fixed in CVS


Note You need to log in before you can comment on or make changes to this bug.