This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 63455 - vicious-build-scripts fails with basic-xft.c segfault
vicious-build-scripts fails with basic-xft.c segfault
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: gcc (Show other bugs)
7.2
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-04-14 01:54 EDT by Need Real Name
Modified: 2008-05-01 11:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-14 21:43:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
hopefully this will help (though i am unsure, and don't know if i should have just cut-n-pasted parts needed or whole file, so here's the whole file) (366.88 KB, text/plain)
2002-04-14 01:56 EDT, Need Real Name
no flags Details

  None (edit)
Description Need Real Name 2002-04-14 01:54:17 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.0 (X11; Linux i686; U;) Gecko/20020326

Description of problem:
Bad: failed to build gnome2 as test user

Good: Didn't install system-wide so system is still up and running.



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.run bootstrap.sh from vicious-build-scripts (no errors)
2.rebuild.sh fails with compile of basic-xft.c (segfault)
3.ran the gcc command second time to produce basic-xft.i (attached)
	

Actual Results:  build of gnome2 from cvs fails

Expected Results:  set up test user for gnome2 to help further development by
bug reporting

Additional info:

system is:

gigabyte 7vtxe motherboard (kt266a)
athlon xp 1800 cpu
redhat 7.2 with updates from ximian.com and redhat.com
 
if need more hardware specs, please request.

kernel is 2.4.9-31 (fairly standard packages)
rpm package database is valid
Comment 1 Need Real Name 2002-04-14 01:56:56 EDT
Created attachment 53767 [details]
hopefully this will help (though i am unsure, and don't know if i should have just cut-n-pasted parts needed or whole file, so here's the whole file)
Comment 2 Owen Taylor 2002-04-14 18:49:34 EDT
does running gcc on the .i file actually reproduce the segfault?
Comment 3 Need Real Name 2002-04-14 21:43:23 EDT
not sure if this is correct but ran: 

$ gcc -DHAVE_CONFIG_H -I. -I. -I../.. -DPANGO_ENABLE_ENGINE
-DG_DISABLE_DEPRECATED -I../.. -I../../pango/ -I/usr/X11R6/include
-I/usr/include/freetype2 -g -O2 -Wall -D_REENTRANT
-I/opt/gnome/head/INSTALL/include/glib-2.0
-I/opt/gnome/head/INSTALL/lib/glib-2.0/include -Wp,-MD,.deps/basic-xft.pp -c
basic-xft.i -fPIC -DPIC -o basic-xft.lo

and there was no segfault, if this is incorrect gcc syntax, please let me know
Comment 4 Jakub Jelinek 2002-04-15 03:36:32 EDT
I cannot reproduce it either. This means that it is very likely a hardware
problem.
Comment 5 Need Real Name 2002-04-16 00:35:18 EDT
If you have the time, what type of hardware problem should I be looking for?  I
can compile kernels fine but the GNOME stuff, either garnmoe or
vicious-build-scripts fails.
Comment 6 Need Real Name 2002-04-25 15:21:09 EDT
actually it seems it was a but with ximian's gtk+ which i was using.  ximian
released a new version of gtk+ and works fine now, so it wasn't a hardware
problem afterall.

Note You need to log in before you can comment on or make changes to this bug.