Bug 635003 - yum complains about libcurl.so.4
Summary: yum complains about libcurl.so.4
Keywords:
Status: CLOSED CANTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: yum
Version: 12
Hardware: All
OS: Linux
low
urgent
Target Milestone: ---
Assignee: Seth Vidal
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-09-17 15:04 UTC by Ahamed Rasheed C K
Modified: 2014-01-21 23:16 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-09-20 15:26:45 UTC


Attachments (Terms of Use)

Description Ahamed Rasheed C K 2010-09-17 15:04:14 UTC
Description of problem:

today when i tried to update using yum it complains that 


There was a problem importing one of the Python modules
required to run yum. The error leading to this problem was:

   /usr/local/zend/lib/libcurl.so.4: cannot restore segment prot after reloc: Permission denied

Please install a package which provides this module, or
verify that the module is installed correctly.

It's possible that the above module doesn't match the
current version of Python, which is:
2.6.2 (r262:71600, Jun  4 2010, 18:28:04) 
[GCC 4.4.3 20100127 (Red Hat 4.4.3-4)]

If you cannot solve this problem yourself, please go to 
the yum faq at:
  http://yum.baseurl.org/wiki/Faq
  

[root@localhost ahamedck]# 





Version-Release number of selected component (if applicable):


How reproducible:
today only i noticed it and now i an not in a position to install any more s/w

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 seth vidal 2010-09-20 15:26:45 UTC
Looks like you installed a new version of curl in a library lookup path that precedes the normal lookup in /usr/lib. If you remove the 

file from
 /usr/local/zend/lib/libcurl.so.4

or change the library lookup order this problem will go away.

Comment 2 Ahamed Rasheed C K 2010-09-23 08:27:15 UTC
Hi, 
How I could change the library lookup order Pl.

Rasheed

Comment 3 seth vidal 2010-09-24 13:39:49 UTC
you'll want to look up about LD_LIBRARY_PATH and how to set the order of the lookup.


Note You need to log in before you can comment on or make changes to this bug.