Bug 63589 - nautilus doesn't come back up after logout/login
nautilus doesn't come back up after logout/login
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: nautilus (Show other bugs)
skipjack-beta2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-04-15 20:55 EDT by David Paschal
Modified: 2007-04-18 12:42 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-05-05 22:53:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Requested systrace output (78.40 KB, text/plain)
2002-04-23 17:34 EDT, David Paschal
no flags Details
nautilus is not anywhere in ~/.gnome/session (2.83 KB, text/plain)
2002-04-23 17:36 EDT, David Paschal
no flags Details
output of "strace -o output -f gconftool-1 --shutdown" (hangs on last select) (15.12 KB, text/plain)
2002-04-23 18:55 EDT, David Paschal
no flags Details

  None (edit)
Description David Paschal 2002-04-15 20:55:56 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.72 [en] (X11; U; Linux 2.2.18-dsp1 i686)

Description of problem:
In the first Gnome login session in which I run Nautilus (or "Start here"), it
works fine, and I can start it as many times as I want. 

However, if I then logout and back in again, nautilus no longer comes up.  If I
run "nautilus" in a terminal window, it gives the error message "Gdk-WARNING **:
locale not supported by Xlib, local set to C" (this message appears to be
normal), and the command just sits there and no windows come up (I can press
Ctrl-C to get back to the command line).

After a logout, "/usr/bin/gconfd-1" and sometimes "nautilus" processes are still
running by the user in question.

It appears to be necessary to reboot the computer in order to run nautilus
again, regardless of whether I clean out the /tmp directory and/or kill any
leftover processes such as gconfd or nautilus.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. (Re)boot the computer.
2. Log into Gnome.
3. Click on the "Start here" icon.  Close the window and repeat as many times as
desired.  Nautilus comes up correctly each time.
4. Log out of Gnome.
5. Log back into Gnome.
6. Click on "Start here".  Nautilus doesn't come up at all, but it should have.

Additional info:
Comment 1 Havoc Pennington 2002-04-15 21:47:08 EDT
Some things to try:
 - be sure nautilus is in ~/.gnome/session
 - try changing your locale to something definitely valid 
    like en_US to avoid the Xlib warning, that isn't normal
    (but I think it's a fixed bug, just Xlib not understanding 
    iso885915 locales)
 - "strace -o output -f nautilus" from a terminal, wait for nautilus
    to hang, hit control-C, send along the file "output"

thanks!
Comment 2 David Paschal 2002-04-23 17:34:50 EDT
Created attachment 55085 [details]
Requested systrace output
Comment 3 David Paschal 2002-04-23 17:36:59 EDT
Created attachment 55086 [details]
nautilus is not anywhere in ~/.gnome/session
Comment 4 David Paschal 2002-04-23 17:39:24 EDT
"LANG=en_US nautilus &" made the Xlib warning go away.  (LANG was set to
"en_US.iso885915".)
Comment 5 Havoc Pennington 2002-04-23 18:24:21 EDT
It still hangs when the warning goes away, right.
Comment 6 Havoc Pennington 2002-04-23 18:28:25 EDT
What version of gconf? Does "gconftool-1 --shutdown" help any while it's stuck?
Does gconf-sanity-check-1 report any issues?

The lack of nautilus in the session and the hang are perhaps different issues...
Comment 7 David Paschal 2002-04-23 18:53:14 EDT
Yes, with or without the Xlib warning, nautilus hangs on the select() call near
the end of the strace file, and I pressed Ctrl-C to kill it.  (I didn't start it
in the background.)

"rpm -qf /usr/bin/gconf-config" reports package "GConf-devel-1.0.9-3".
"rpm -qf /usr/bin/gconftool-1" reports package "GConf-1.0.9-3".

"gconftool-1 --shutdown" gets stuck the same way nautilus does.

[dpaschal@paschal6 dpaschal]$ gconf-sanity-check-1 
Please contact your system administrator to resolve the following problem:
Failed to get a file lock: Failed to lock '/home/dpaschal/.gconfd/lock/ior':
probably another process has the lock, or your operating system has NFS file
locking misconfigured, or a hard NFS client crash caused a stale lock (Resource
temporarily unavailable) - run gconf-sanity-check-1 for possible diagnosis, see
http://www.gnome.org/projects/gconf/ for more information

[dpaschal@paschal6 dpaschal]$ ls -slap /home/dpaschal/.gconfd/lock/ior 
   4 -rwx------    1 dpaschal dpaschal      265 Apr 15 17:42
/home/dpaschal/.gconfd/lock/ior

[dpaschal@paschal6 dpaschal]$ /usr/sbin/lsof |grep gconfd     
gconfd-1   2105 dpaschal  cwd    DIR        3,2    4096         2 /
gconfd-1   2105 dpaschal  rtd    DIR        3,2    4096         2 /
gconfd-1   2105 dpaschal  txt    REG        3,2   53073     16246 /usr/bin/gconfd-1
gconfd-1   2105 dpaschal  mem    REG        3,2   90327    241009 /lib/ld-2.2.5.so
gconfd-1   2105 dpaschal  mem    REG        3,2   42514    353550
/usr/lib/GConf/1/libgconfbackend-xml.so
gconfd-1   2105 dpaschal  mem    REG        3,2  265551     96676
/usr/lib/libgconf-1.so.1.0.4
gconfd-1   2105 dpaschal  mem    REG        3,2  123100     96573
/usr/lib/liboaf.so.0.0.0
gconfd-1   2105 dpaschal  mem    REG        3,2   29376     96464
/usr/lib/libpopt.so.0.0.0
gconfd-1   2105 dpaschal  mem    REG        3,2   41594     96504
/usr/lib/libORBitCosNaming.so.0.5.13
gconfd-1   2105 dpaschal  mem    REG        3,2  288277     96502
/usr/lib/libORBit.so.0.5.13
gconfd-1   2105 dpaschal  mem    REG        3,2   64549     96500
/usr/lib/libIIOP.so.0.5.13
gconfd-1   2105 dpaschal  mem    REG        3,2    7043     96506
/usr/lib/libORBitutil.so.0.5.13
gconfd-1   2105 dpaschal  mem    REG        3,2   89424    241026
/lib/libnsl-2.2.5.so
gconfd-1   2105 dpaschal  mem    REG        3,2  173487    241005
/lib/i686/libm-2.2.5.so
gconfd-1   2105 dpaschal  mem    REG        3,2   11931     96453
/usr/lib/libgmodule-1.2.so.0.0.10
gconfd-1   2105 dpaschal  mem    REG        3,2  182363     96451
/usr/lib/libglib-1.2.so.0.0.10
gconfd-1   2105 dpaschal  mem    REG        3,2   12102    241022
/lib/libdl-2.2.5.so
gconfd-1   2105 dpaschal  mem    REG        3,2   45415    241042
/lib/libnss_files-2.2.5.so
gconfd-1   2105 dpaschal  mem    REG        3,2  499990     96496
/usr/lib/libxml.so.1.8.17
gconfd-1   2105 dpaschal  mem    REG        3,2   59778     96445
/usr/lib/libz.so.1.1.3
gconfd-1   2105 dpaschal  mem    REG        3,2 1401050    241003
/lib/i686/libc-2.2.5.so
gconfd-1   2105 dpaschal    0u   CHR        1,3             66338 /dev/null
gconfd-1   2105 dpaschal    1u   CHR        1,3             66338 /dev/null
gconfd-1   2105 dpaschal    2u   CHR        1,3             66338 /dev/null
gconfd-1   2105 dpaschal    3u   CHR        1,3             66338 /dev/null
gconfd-1   2105 dpaschal    4u  unix 0xc20cd0e0             10187 socket
gconfd-1   2105 dpaschal    5u  unix 0xc0b6ba60             10188
/tmp/orbit-dpaschal/orb-18907697101992247766
gconfd-1   2105 dpaschal    6w   REG        3,2     265    164848
/home/dpaschal/.gconfd/lock/0t1018917774ut195181u500p2105r546168450k3221149756
(deleted)
gconfd-1   2105 dpaschal    7w   REG        3,2     265    116222
/home/dpaschal/.gconf/%gconf-xml-backend.lock/1t1018917774ut236861u500p2105r137935288k3221149372
(deleted)
gconfd-1   2105 dpaschal    8r   REG        3,2     876    421381
/home/dpaschal/.gconfd/saved_state.orig (deleted)
gconfd-1   2105 dpaschal    9r  FIFO        0,6             10198 pipe
gconfd-1   2105 dpaschal   10w  FIFO        0,6             10198 pipe
gconfd-1   2105 dpaschal   11u  unix 0xc0b6b060             10199
/tmp/orbit-dpaschal/orb-18907697101992247766
gconfd-1   2105 dpaschal   13u  unix 0xc03ed0a0             10219 socket
Comment 8 David Paschal 2002-04-23 18:55:07 EDT
Created attachment 55124 [details]
output of "strace -o output -f gconftool-1 --shutdown" (hangs on last select)
Comment 9 Havoc Pennington 2002-04-24 10:37:26 EDT
Essentially it looks like gconfd isn't responding.

Tracing gconfd could be interesting. Also the syslog stuff 
as described on http://www.gnome.org/projects/gconf/
Comment 10 Jim Shanks 2002-05-05 22:53:12 EDT
This appears to be the same bug as 62920.  In any case the resolution suggested 
by alexl@redhat.com in 62920 (Try upgrading to xinetd 2.3.4-0.8 from rawhide. 
The shut down portmap and xinetd and then start them again.) Works.
Comment 11 Havoc Pennington 2002-07-03 14:45:15 EDT
Hmm, bug should have been closed a good long time ago it seems.

Note You need to log in before you can comment on or make changes to this bug.