Bug 636565 - RFE: needs install machine only with @base group
RFE: needs install machine only with @base group
Status: CLOSED CURRENTRELEASE
Product: Beaker
Classification: Community
Component: general (Show other bugs)
0.6
All Linux
high Severity medium (vote)
: 0.6.11
: ---
Assigned To: Bill Peck
: Reopened
Depends On:
Blocks: 545868
  Show dependency treegraph
 
Reported: 2010-09-22 11:05 EDT by Petr Sklenar
Modified: 2015-05-03 21:46 EDT (History)
20 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-07-17 18:23:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Petr Sklenar 2010-09-22 11:05:47 EDT
Description of problem:
We need install machine only with @base + needed beaker packages and not any other, without needs of own kickstart.

Beaker Version:
0.5.57 
  
Actual results:
Beaker installs more packages than its in @base group. 
When we schedule single task and beaker machine is installed then there are many groups in section %packages of file /root/cobbler.ks

Expected results:
there is option in Makefile to have ability  to install only @base / @core group.

for ex:
Makefile:
@echo "Requires:        @base" >> $(METADATA)
and that's it

Additional info:
it blocks our testing of missing dependencies 627859#c9
Having own kickstarts for each rhel distro is too much maintaining.
Comment 1 Jan Pazdziora 2010-09-22 11:16:02 EDT
(In reply to comment #0)
> 
> 
> Expected results:
> there is option in Makefile to have ability  to install only @base / @core
> group.

In my opinion, it should not be an option of our tests, it should be a parameter to /distribution/install, or maybe some attribute of recipe/packages.

The business justification for this RFE is that we just had a false positive while testing Satellite because we had an extra package installed which happened to address certain issue. But the customer will not have that package installed because it was not pulled in via Required for our packages -- it was just there already.

That's why we need to be able to get the distribution as bare as possible (while understanding that the beaker client side requirement will need to be there).
Comment 3 Bill Peck 2010-12-15 09:41:37 EST
I'm trying to figure out how to make two groups happy.  The desktop group requested that these be there for the default install.  They argue that the automated install should act like the default manual install.

I'm cc'ing rousseau@redhat.com to see if he has any suggestions.
Comment 4 Jan Pazdziora 2010-12-15 09:54:50 EST
(In reply to comment #3)
> I'm trying to figure out how to make two groups happy.  The desktop group
> requested that these be there for the default install.  They argue that the
> automated install should act like the default manual install.
> 
> I'm cc'ing rousseau@redhat.com to see if he has any suggestions.

So is this configured in beaker or is that kickstart configuration in the lab which defines the groups?

I can imagine we could start our tests with

   <packages>@base</packages>

but the problem is that <packages> only add, not override the default group selection. So if there was some other tag (or attribute to packages) which would allow us to override the default, that would be completely sufficient.

If on the other hand, if it's distro/kickstart configuration in the lab, maybe new set of kickstart/distros would be created, and we would simply /distribution/install RHEL5-Server-U5-base instead of RHEL5-Server-U5.
Comment 5 Bill Peck 2010-12-15 15:11:40 EST
I've added this as an item to bring up in the stake holder meeting.
Comment 6 Marian Ganisin 2010-12-16 02:02:48 EST
Fix seems to be quite simple from my point of view, thanks to cheetah. Is it problem to add some kind of ks_meta in sort of "suppress-desktop" to omit these packages?

Question is what's reasonable default. In my opinion it is @base and "enable-desktop" ks_meta as option.

And when implementing this RTT would really appreciate also existence of ks_meta like "packages-empty" for clean/(or no) %packages section
Comment 7 Bill Peck 2010-12-16 09:44:08 EST
It is simple, the hard part is nailing down all the different combinations and getting sane defaults.

I think I need to create a table to see all the combinations.  Adding in Cameron to this ticket so its not a surprise.
Comment 8 Daniel Mach 2011-04-20 04:15:43 EDT
I also need only @core and @base groups when running reserve workflow.
I install additional packages manually afterwards.

Installing only these groups would trim installation times to absolute minimum (it takes about 5 minutes to install minimal rhel5 to a xen PV guest...).
Comment 10 Marian Ganisin 2013-08-26 07:15:35 EDT
just a note regarding to @base group. As far as I know Fedora intentionally does not contain @base anymore and there's new @standard group. So desired default installation may vary on different distributions.
Comment 11 Orion Poplawski 2014-07-17 13:28:13 EDT
What's the status here?
Comment 12 Dan Callaghan 2014-07-17 18:23:38 EDT
(In reply to Orion Poplawski from comment #11)

I'm not sure what happened to the bug state here, but this was indeed fixed a long time ago in Beaker 0.6.11.

https://git.beaker-project.org/cgit/beaker/commit/?id=a6a65e0577f2f8cf02fcc1957c6f94c46b28703d

Beaker populates %packages with only the packages required by the tasks in the recipe, nothing more. Anaconda implicitly adds @core so that you get a kernel and whatnot. For manual reservations (no recipe) Beaker instead puts %packages --default, which gives you the same package set as a human clicking through the graphical install.

As a compromise the dependencies that were previously hardcoded in the kickstart are now listed as requirements of /distribution/install. It's not an ideal solution (it's difficult for us to ever remove them now, because of the breakage it would cause) but it means you can opt out of /distribution/install or use an alternative version without the heavy requirements.
Comment 13 Dan Callaghan 2014-07-17 18:25:28 EDT
Ah, I just noticed that this bug is on the wrong product, which must be why you were pinging it Orion :-)
Comment 14 Marian Ganisin 2014-07-18 04:02:25 EDT
Actually some of these additional packages are added by /distribution/install task which is now part of beaker and it is added to each recipe by default:


    @desktop-platform-devel
    @development
    @development-libs
    @development-tools
    @server-platform-devel
    expect
    gcc
    libxml2-python
    make
    nfs-utils
    ntp
    procmail
    pyOpenSSL
    redhat-lsb
    wget


So this bug might be considered fixed in same way as still present. ;)

Luckily /distribution/install isn't much important or useful and it can be removed from the job without significant impact (/distribution/dummy can be placed instead of it to keep the results "nice"). Command line tools have option for this. Anyway this is just a workaround and as such it does not have to satisfy all the users.

Note You need to log in before you can comment on or make changes to this bug.