Bug 63700 - konqueror crashes when starting in filemanagement mode
konqueror crashes when starting in filemanagement mode
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: kdebase (Show other bugs)
1.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: wdovlrrw
Ben Levenson
:
Depends On:
Blocks: 67218
  Show dependency treegraph
 
Reported: 2002-04-17 11:48 EDT by Markku Kolkka
Modified: 2007-04-18 12:42 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-07-16 16:59:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Backtrace (3.45 KB, text/plain)
2002-04-17 11:49 EDT, Markku Kolkka
no flags Details
Evil crash-inducing profile (1.07 KB, text/plain)
2002-04-17 12:41 EDT, Markku Kolkka
no flags Details

  None (edit)
Description Markku Kolkka 2002-04-17 11:48:46 EDT
Description of Problem:  
Konqueror crashes immediately with SIGSEGV whenever I try to start it in file manager  
mode, either from the "home directory" icon in the panel, or by trying to load the file  
manager profile into running instance of Konqueror (using the Window->Load view profile  
menu item).  
  
Version-Release number of selected component (if applicable):  
kdebase-3.0.0-9  
  
How Reproducible:  
Always  
  
Steps to Reproduce:  
1. Click "Home directory" icon in KDE bottom panel.  
2.   
3.   
  
Actual Results:  
Crash with signal 11 (SIGSEGV)  
  
Expected Results:  
Konqueror starts in file manager mode  
  
Additional Information:  
Browsing directories works when Konqueror is in "WWW browser" mode.
Comment 1 Markku Kolkka 2002-04-17 11:49:36 EDT
Created attachment 54189 [details]
Backtrace
Comment 2 Bernhard Rosenkraenzer 2002-04-17 12:07:59 EDT
Not reproducable here. Do you have anything odd in your home directory (e.g. 
files that would generate a strange thumbnail or something)?
Comment 3 Markku Kolkka 2002-04-17 12:40:29 EDT
The problem seems to be with the profile file 
(~/.kde/share/apps/konqueror/profiles/filemanagement), inherited from KDE2. Deleting the 
old file made file management work again. IMHO, crashing due to a config file error is 
still a serious bug. I'll attach the crash-causing profile file.
Comment 4 Markku Kolkka 2002-04-17 12:41:35 EDT
Created attachment 54190 [details]
Evil crash-inducing profile
Comment 5 Ngo Than 2002-07-16 16:59:32 EDT
it's fixed in kdebase-3.0.2-3. i cannot reproduce it with your corupt
filemanagement.
Comment 6 Jay Turner 2002-09-03 20:30:07 EDT
Not seeing any problems with kdebase-3.0.3-10.

Note You need to log in before you can comment on or make changes to this bug.