Bug 637117 - Fix nfs/rpcsvcgssd start priorities
Fix nfs/rpcsvcgssd start priorities
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: nfs-utils (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Steve Dickson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-09-24 07:00 EDT by Zdenek Kabelac
Modified: 2011-10-04 11:30 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-10-04 11:30:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Log output of systemctl restart nfs.service (4.93 KB, text/plain)
2010-09-24 07:00 EDT, Zdenek Kabelac
no flags Details

  None (edit)
Description Zdenek Kabelac 2010-09-24 07:00:46 EDT
Created attachment 449392 [details]
Log output of systemctl restart nfs.service

Description of problem:

While I've been using nfs before I switched to systemd - I'm not able to start this service with systemd anymore.

Here is just something for 'linux systemd guru masters' which are probably able to decrypt the reason of nfs failure?


Version-Release number of selected component (if applicable):
systemd-10-4.fc15.x86_64

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Michal Schmidt 2010-09-24 07:13:52 EDT
This is another case of a deadlock when starting of a service triggers a synchronous start of another one, but the latter has an After dependency on the first one.
Specifically here /etc/init.d/nfs does:
   ...
   start)
      ...
      [ -x /usr/sbin/rpc.svcgssd ] && /sbin/service rpcsvcgssd start
      ...

And "systemctl show rpcsvcgssd.service" says:
  After=... nfs.service ...
Comment 2 Zdenek Kabelac 2010-09-24 07:26:19 EDT
Usable workaround here seems to be:

SYSTEMCTL_SKIP_REDIRECT=1 /etc/init.d/nfs restart
Comment 3 Bill Nottingham 2010-09-24 12:36:45 EDT
If nfs has a unilateral dep on rpcsvcgssd such that it starts it always, it shouldn't have a chkconfig priority set earlier than rpcsvcgssd.
Comment 4 Zdenek Kabelac 2010-09-25 09:08:46 EDT
I'm starting nfs only when I need to use on my machine i.e. for kvm guest - there is no reason to run this service all the time or even have it available on demand.
Comment 5 Steve Dickson 2010-09-27 09:10:54 EDT
> If nfs has a unilateral dep on rpcsvcgssd such that it starts it always, it
> shouldn't have a chkconfig priority set earlier than rpcsvcgssd
No. rpcsvcgssd is only need if the NFS server is exported 
secure exports (i.e. exports with the 'sec=krb5:krb5i:krb5p' opts).

To enable the daemon one needs to set the  SECURE_NFS=yes
in /etc/sysconfig/nfs.
Comment 6 Bill Nottingham 2010-09-27 13:01:03 EDT
Still, there's no reason for it to have a hardcoded later priority, if in the circumstances where it is needed, it is always needed before nfsd.
Comment 7 Steve Dickson 2010-12-01 15:14:41 EST
There are plans afoot to combined the client side daemon (rpc.gssd)
and the server side daemon (rpc.svcgssd) into one daemon. When
that happens (hopefully by f15) I'll remove the hard coded call
to rpc.svcgssd from the nfs start up script.

Note You need to log in before you can comment on or make changes to this bug.