Bug 63721 - xemacs started in X survives restarting X
xemacs started in X survives restarting X
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: xemacs (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Trond Eivind Glomsrxd
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-04-17 16:55 EDT by Adrian Likins
Modified: 2007-04-18 12:42 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-23 16:26:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Adrian Likins 2002-04-17 16:55:00 EDT
Description of Problem:

If I startx, then start xemacs, and then quit X (either ctrl-alt-backspace) or
via the gnome logout menu item, when I return to the console,
xemacs is still running. If I start X again, xemacs will
start to take 99% of cpu time. 

Version-Release number of selected component (if applicable):
xemacs-21.4.6-7


How Reproducible:
So far everytime I've tried.

Steps to Reproduce:
1. start x
2. start xemacs
3. exit x

Actual Results:

xemacs continues to run

Expected Results:
xemacs would be killed.
Comment 1 Trond Eivind Glomsrxd 2002-04-22 19:04:17 EDT
Can't reproduce at all, tried with gnome, kde in gdm and with startx, exiting
with log out and with ctrl-alt-backspace
Comment 2 Adrian Likins 2002-04-23 15:44:21 EDT
Dunno, it does it for me with fvwm/gnome and startx on
my laptop, fvwm/gnome/startx on my home machine, and fvwm/gnome/gdm 
on my test box. Also with sawfish/gnome/gdm on my testbox.

tristan.devel.redhat.com to see it...

Comment 3 Trond Eivind Glomsrxd 2002-04-23 16:16:59 EDT
Does it happen on a fresh install of the final when running in the default gnome
or kde environments?
Comment 4 Adrian Likins 2002-04-23 16:26:07 EDT
dunno, I dont use any of those enviroments. The test box
was a clean install from a tree about a week old (xemacs-21.4.6-7)
but pulled up2date with whatever the latest in the RHN servers are.

The laptop and home machine are both upgrades (one from 7.2+, the
other from 7.1)

test machine doesnt seem to do it with a pristine new user setup

It seems to fail in every other enviroment I have access to however...
Comment 5 Trond Eivind Glomsrxd 2002-07-31 12:48:39 EDT
Still never seen it happen. Reopen if you find a way to reproduce it on a
current system with standard components.

Note You need to log in before you can comment on or make changes to this bug.