Bug 637252 - virt-resize has no 32-bit support
virt-resize has no 32-bit support
Status: CLOSED UPSTREAM
Product: Virtualization Tools
Classification: Community
Component: libguestfs (Show other bugs)
unspecified
All Linux
low Severity medium
: ---
: ---
Assigned To: Richard W.M. Jones
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-09-24 13:21 EDT by Eric Blake
Modified: 2011-04-12 13:50 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-04-12 13:50:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Eric Blake 2010-09-24 13:21:47 EDT
Description of problem:
virt-resize is useless on a 32-bit host

Version-Release number of selected component (if applicable):
libguestfs-1.5.18-1.fc14.2.i686
libguestfs-tools-1.5.18-1.fc14.2.i686


How reproducible:
always

Steps to Reproduce:
1. virt-resize --help (or any actual resize command attempt)
  
Actual results:
# virt-resize --help
virt-resize: sorry this program does not work on a 32 bit host


Expected results:
disk image management is not unique to 64-bit hosts.  virt-resize should be able to operate when run on a 32-bit host, since all of the underlying tools used during resizing, such as parted, lvm, and so forth, all have 32-bit counterparts.

Additional info:

Note You need to log in before you can comment on or make changes to this bug.