Bug 63741 - ssh-add may never exit with gnome-askpass
Summary: ssh-add may never exit with gnome-askpass
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gnome-libs (Show other bugs)
(Show other bugs)
Version: 7.2
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Ray Strode [halfline]
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-04-18 08:21 UTC by Gordon Messmer
Modified: 2007-04-18 16:42 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-08 14:47:56 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Gordon Messmer 2002-04-18 08:21:28 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.0 (X11; Linux i686; U;) Gecko/20020314

Description of problem:
Due to a change in readpass.c, it is possible that ssh-add will hang forever
trying to read a passphrase from gnome-ssh-askpass.  With 2.9p2, readpass.c
would attempt one read() from the askpass program.  In 3.1p1, the read() call is
in a while loop which will exit when the pipe closes (and read() returns -1) or
when the buffer fills.  

If gnome-ssh-askpass is the first gnome application run, and esd is not
disabled, then gnome-ssh-askpass starts esd as a child.  This esd process
inherits all of the open files from the gnome-ssh-askpass process, including the
pipe to ssh-add.  gnome-ssh-askpass will exit, but ssh-add will continue to try
to read from the pipe which esd has open.  This leaves the X display blank, and
in some configurations, prevent the rest of the login from proceeding.

Probably the obvious fix would be to modify gnome-libs so that before esd is
started, all open files are closed.

Version-Release number of selected component (if applicable):
openssh-3.1p1-2

How reproducible:
Always

Steps to Reproduce:
1. Use the following in .Xclients:
#!/bin/sh
eval `ssh-agent -s`
ssh-add
gnome-session
ssh-agent -k

2. Log in to X.
	

Actual Results:  After entering the passphrase into the gnome-ssh-askpass
dialog, no windows appear.

Expected Results:  After entering the passphrase into the gnome-ssh-askpass
dialog, gnome starts.

Additional info:

Comment 1 Tomas Mraz 2005-02-03 12:46:29 UTC
>Probably the obvious fix would be to modify gnome-libs so that before
>esd is started, all open files are closed.

Yes, of course.

However maybe it was already fixed? Please test with current Fedora Core.



Comment 2 Ray Strode [halfline] 2005-04-08 14:47:56 UTC
Hi.

If this problem still exists in a recent version of Fedora Core or RHEL please
reopen.

Thanks.


Note You need to log in before you can comment on or make changes to this bug.