Bug 63746 - Group/optional package handling
Group/optional package handling
Status: CLOSED WONTFIX
Product: Stronghold Cross Platform
Classification: Retired
Component: catapult (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Joe Orton
Stronghold Engineering List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-04-18 06:34 EDT by Joe Orton
Modified: 2007-04-18 12:42 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-05 16:42:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joe Orton 2002-04-18 06:34:10 EDT
Description of Problem:
A problem exists where php3 is always installed on an upgrade due to the logic
"if an optional package P exists in the sfx where the group matches a package Q
which is already upgraded, always install the package P."

Steps to Reproduce:
1. Install without php3
2. Upgrade existing installation

Actual Results:
Not prompted for selection of php3 package.

Expected Results:
php3 should be listed in optional package selection.

Additional Information:
Suggested correct fix is to:
- abandon optional package groups based on the Group field
- change catapult to loop resolving dependencies based on suggestedPackages,
as update-agent does
Comment 1 Joe Orton 2004-04-05 16:42:10 EDT
Too intrusive to fix in 4.0x updates.

Note You need to log in before you can comment on or make changes to this bug.