Bug 63747 - neat crashes when trying to change a DNS field
neat crashes when trying to change a DNS field
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-network (Show other bugs)
7.2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Trond Eivind Glomsrxd
:
: 60358 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-04-18 06:50 EDT by Need Real Name
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-18 14:56:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-04-18 06:50:00 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.78 [en] (X11; U; Linux 2.4.7-10 i686)

Description of problem:
I try to use neat after having migrated from RH7.0 to RH7.2
The program just crashes when it tries to save information

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.neat (mentioning of copying  ifcfg-eth0 etc. to default profile)
2.I go to he DNS tab and change an IP entry or whatever
3.Press apply
	

Actual Results:  Please visit http://bugzilla.redhat.com/bugzilla/ !
File a bug against component redhat-config-network. Thank you!

Traceback (innermost last):
  File "/usr/sbin/neat", line 1210, in ?
    gtk.mainloop()
  File "/usr/lib/python1.5/site-packages/gtk.py", line 2608, in mainloop
    _gtk.gtk_main()
  File "/usr/lib/python1.5/site-packages/libglade.py", line 28, in __call__
    ret = apply(self.func, a)
  File "/usr/sbin/neat", line 392, in on_applyButton_clicked
    self.save()
  File "/usr/sbin/neat", line 271, in save
    self.saveHardware()
  File "/usr/sbin/neat", line 283, in saveHardware
    hardwarelist.save()
  File "/usr/sbin/../share/redhat-config-network/netconfpkg/NCHardwareList.py",
line 276, in save
    modules.write()
  File "/usr/sbin/../share/redhat-config-network/netconfpkg/Conf.py", line 981,
in write
    self[key] = self.vars[key]
  File "/usr/sbin/../share/redhat-config-network/netconfpkg/Conf.py", line 933,
in __setitem__
    findexp = '[\t ]*' + key + '[\t ]+' + varname + '[\t ]+'
TypeError: illegal argument type for built-in operation


Expected Results:  I want to configure my network....
Some tool (and I haven't figured out wich one) keeps changing back my
/etc/resolv.conf file, previously managed by linuxconf


Additional info:

I did an upgrade installation of RH7.0 to RH7.2
Comment 1 Trond Eivind Glomsrxd 2002-04-18 13:09:16 EDT
Please try 0.9.30-1 at http://people.redhat.com/teg/neat/

I'm pretty sure this was fixed some time ago.
Comment 2 Need Real Name 2002-04-18 14:17:37 EDT
I thought I downloaded the latest version from the redhat web site (
redhat-config-network-0.9.10-2.noarch.rpm). Apparantly this version (although
newer than the one in the 7.2 distribution) still had this bug.
redhat-config-network-0.9.30-1.i386.rpm solved my problem,
Thanks for the help.
Comment 3 Trond Eivind Glomsrxd 2002-04-18 14:57:29 EDT
Closing as rawhide, as it initially was a bug. The release above is a
development version, not the current errata release.
Comment 4 Harald Hoyer 2002-06-26 10:48:52 EDT
*** Bug 60358 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.