Bug 63776 - Konsole only shows cryptic error message in case session could not be started
Konsole only shows cryptic error message in case session could not be started
Status: CLOSED NEXTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kdebase (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Petr Rockai
Ben Levenson
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-04-18 13:48 EDT by Wade Minter
Modified: 2007-04-18 12:42 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-17 10:37:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Wade Minter 2002-04-18 13:48:19 EDT
Description of Problem:

Performed an installation of beta4, choosing KDE, but not gnome.

Within konsole, if you hold the "New" button, you get options for "Midnight
Commander" and "Root Midnight Commander".

Using either of those options launches a new konsole that immediately exits. 
Odds are it's trying to run a binary that's not installed.

Either there should be a dependancy on mc for konsole, or those tabs should not
show up unless mc is installed.
Comment 1 Bernhard Rosenkraenzer 2002-06-10 10:24:17 EDT
Did you install midnight commander? 
Comment 2 Wade Minter 2002-06-10 21:23:11 EDT
No, no mc RPMs on the system.
Comment 3 Petr Rockai 2005-03-11 11:28:01 EST
Dependency is far too heavy for this. However, an more verbose error could be      
printed than "session midnight commander ended with error code 127" which is     
what is printed now... Will forward upstream as a wishlist.   
Comment 4 Petr Rockai 2006-01-17 10:37:00 EST
This will be fixed in a future Fedora release if upstream provides a solution.  
The issue is recorded here: http://bugs.kde.org/show_bug.cgi?id=120322 
 
Please direct your further comments or remarks to this KDE Bugzilla entry, 
thanks. 
Comment 5 Petr Rockai 2006-01-30 13:15:05 EST
The problem will be fixed in the upcoming Fedora Core 5, that is, the session 
types that are not available (their executables are missing) are not shown in 
the menus. 

Note You need to log in before you can comment on or make changes to this bug.