Bug 637937 - register with autosubscribe fails to consume RHEL Personal Bits
Summary: register with autosubscribe fails to consume RHEL Personal Bits
Keywords:
Status: CLOSED DUPLICATE of bug 672438
Alias: None
Product: Candlepin
Classification: Community
Component: candlepin
Version: 0.5
Hardware: All
OS: Solaris
low
high
Target Milestone: ---
: ---
Assignee: Devan Goodwin
QA Contact: John Sefler
URL:
Whiteboard:
Depends On:
Blocks: Entitlement-Beta
TreeView+ depends on / blocked
 
Reported: 2010-09-27 19:36 UTC by John Sefler
Modified: 2015-05-14 15:23 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-01-25 16:36:46 UTC


Attachments (Terms of Use)

Description John Sefler 2010-09-27 19:36:09 UTC
Description of problem:
After subscribing to RHEL Personal as type=person, I expect a register with type=system --autosubscribe to automatically consume the available sub pool (RHEL Personal Bits).


Version-Release number of selected component (if applicable):
[root@jsefler-rhel6-client02 ~]# rpm -q subscription-manager
subscription-manager-0.82-1.git.19.4dce2e6.fc12.i386
[root@jsefler-f12-candlepin proxy]# git show-ref master
9f084aa522188b0ccf957d329197ed452f24e8a5 refs/heads/master
9f084aa522188b0ccf957d329197ed452f24e8a5 refs/remotes/origin/master


How reproducible:


Steps to Reproduce:
ON CLIENT1:
[root@jsefler-rhel6-client01 ~]# subscription-manager-cli register --username=testuser1 --password=password --type=person
f6d9b5db-26ae-4cf6-80e6-b480038017c2 testuser1
[root@jsefler-rhel6-client01 ~]# subscription-manager-cli list --available
+-------------------------------------------+
    Available Subscriptions
+-------------------------------------------+


ProductName:       	RHEL Personal            
ProductId:         	RH09XYU34                
PoolId:            	4                        
Quantity:          	10                       
Expires:           	2011-09-26               

[root@jsefler-rhel6-client01 ~]# subscription-manager-cli subscribe --pool=4


ON CLIENT2:
[root@jsefler-rhel6-client02 ~]# subscription-manager-cli register --username=testuser1 --password=password --type=system --autosubscribe
ba51b808-f102-440b-aeb0-2a4802238609 testuser1
[root@jsefler-rhel6-client02 ~]# subscription-manager-cli list --consumed
No Consumed subscription pools to list

^^^^ BANG.  I EXPECTED THE CONSUMED LIST TO CONTAIN
ProductName:       	RHEL Personal Bits

Comment 1 Ajay Kumar Nadathur Sreenivasan 2010-11-16 20:05:37 UTC
The problem was, rhsm used to delete (not store) entitlement certificates, which don't have product data encoded. This usually happens with marketing type products. So, list --consumed behaves as above. 

Anyway, the above issue has been fixed in sha: 582f7d109b4544fcffaf92609b53ada591356792

Comment 2 John Sefler 2010-11-30 22:44:34 UTC
I still do not see the --autosubscribe step binding to the sub-pools as described in https://bugzilla.redhat.com/show_bug.cgi?id=637937#c0 

[root@jsefler-onprem01 ~]# rpm -q subscription-manager
subscription-manager-0.93.2-1.git.26.e1db2f8.fc12.i386

Moving the state back to ASSIGNED

Comment 3 Devan Goodwin 2011-01-14 15:39:58 UTC
Need info on what product certificates were installed on the system attempting to auto-subscribe. 

Please post results of:

ls /etc/pki/product 

And if the number of certs isn't too huge, for each cert:

openssl x509 -text -in /etc/pki/product/37060.pem | grep 2312

Comment 4 Devan Goodwin 2011-01-14 15:43:34 UTC
Also confused about Ajay's attempted fix, does the system (after auto-subscribe) actually get a certificate in /etc/pki/entitlement? This isn't mentioned in the ticket but it looks like he assumed there was, just wanted to verify if this was discussed outside the bz. Thanks!

Comment 5 Devan Goodwin 2011-01-25 16:36:46 UTC
Closing as a duplicate of 672438.

*** This bug has been marked as a duplicate of bug 672438 ***


Note You need to log in before you can comment on or make changes to this bug.