Bug 63825 - usb-ohci fails on Asus A7V333 motherboard
usb-ohci fails on Asus A7V333 motherboard
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Pete Zaitcev
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-04-19 01:17 EDT by Ajay Sharma
Modified: 2007-04-18 12:42 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-06-04 12:13:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ajay Sharma 2002-04-19 01:17:37 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020408

Description of problem:
USB 1.x works fine as I'm using a USB mouse, I'm assuming that the USB 2.0
controller that is onboard the Asus A7V333 isn't being detected correctly.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.install skipjack-beta2
2.boot up and watch the insmod errors

	

Actual Results:  Apr 18 00:23:37 localhost rc.sysinit: Initializing USB
controller (usb-uhci):  succeeded
Apr 18 00:23:37 localhost modprobe: Hint: insmod errors can be caused by
incorrect module parameters, including invalid IO or IRQ parameters
Apr 18 00:23:37 localhost modprobe:
/lib/modules/2.4.18-0.13/kernel/drivers/usb/usb-ohci.o: init_module: No such device
Apr 18 00:23:37 localhost modprobe:
/lib/modules/2.4.18-0.13/kernel/drivers/usb/usb-ohci.o: insmod
/lib/modules/2.4.18-0.13/kernel/drivers/usb/usb-ohci.o failed
Apr 18 00:23:37 localhost modprobe:
/lib/modules/2.4.18-0.13/kernel/drivers/usb/usb-ohci.o: insmod usb-ohci failed


Expected Results:  Initializing USB controller (usb-ohci): succeeded

Additional info:

This is a brand new motherboard on a clean install.  I don't have any USB 2.0
devices to test the ports but it still shouldn't produce errors like it does. 
(this is my first bugzilla bug report, sorry if it sucks)
Comment 1 Pete Zaitcev 2002-06-03 14:42:11 EDT
Does the release do the same thing?
Comment 2 Ajay Sharma 2002-06-04 03:28:54 EDT
yes.  I have since upgraded to redhat 7.3 and the problem still occurs.  I do
have these lines in my /etc/modules.conf file:

alias usb-controller usb-uhci
alias usb-controller1 usb-ohci

And I imagine that add on the correct IO and IRQ parameters for the USB 2.0
controller for it to work correctly.  Since I still don't have any USB2 devices,
I just commented out the second line and the problems obviously went away.
Comment 3 Pete Zaitcev 2002-06-04 12:05:45 EDT
Well, we still do not support 2.0 fully. It is in "opportunistic"
support, which means we build the code and resolve patching
conflicts, but we cannot fix anything if it does not work.

The only 2.0 driver that community supports is EHCI, which
is supposed to be OHCI compatible, but I suspect that old
usb-ohci simply cannot drive the 1.1 subset of the silicon.
I am not sure if this is a bug or not.

For Milan, QA people were going to buy some 2.0 gear, so we'll see.

I do not think I can help here, but please attach output of
lspci -v, I am curious what controller you actually have, so
I can keep it in mind selecting drivers in the future.
Comment 4 Ajay Sharma 2002-06-04 12:13:02 EDT
Here's the output you asked for (hopefully it doesn't get too mangled!):

[root@localhost root]# lspci  -v
00:00.0 Host bridge: VIA Technologies, Inc. VT8367 [KT266]
        Subsystem: Asustek Computer, Inc.: Unknown device 807f
        Flags: bus master, 66Mhz, medium devsel, latency 0
        Memory at e0000000 (32-bit, prefetchable) [size=64M]
        Capabilities: [a0] AGP version 2.0
        Capabilities: [c0] Power Management version 2

00:01.0 PCI bridge: VIA Technologies, Inc. VT8367 [KT266 AGP] (prog-if 00
[Normal decode])
        Flags: bus master, 66Mhz, medium devsel, latency 0
        Bus: primary=00, secondary=01, subordinate=01, sec-latency=0
        Memory behind bridge: dd000000-dedfffff
        Prefetchable memory behind bridge: def00000-dfffffff
        Capabilities: [80] Power Management version 2

00:05.0 Multimedia audio controller: C-Media Electronics Inc CM8738 (rev 10)
        Subsystem: Asustek Computer, Inc.: Unknown device 80e2
        Flags: bus master, stepping, medium devsel, latency 32, IRQ 10
        I/O ports at d800 [size=256]
        Capabilities: [c0] Power Management version 2

00:09.0 USB Controller: VIA Technologies, Inc. USB (rev 50) (prog-if 00 [UHCI])
        Subsystem: Asustek Computer, Inc.: Unknown device 8080
        Flags: bus master, medium devsel, latency 32, IRQ 12
        I/O ports at d400 [size=32]
        Capabilities: [80] Power Management version 2

00:09.1 USB Controller: VIA Technologies, Inc. USB (rev 50) (prog-if 00 [UHCI])
        Subsystem: Asustek Computer, Inc.: Unknown device 8080
        Flags: bus master, medium devsel, latency 32, IRQ 11
        I/O ports at d000 [size=32]
        Capabilities: [80] Power Management version 2

00:09.2 USB Controller: VIA Technologies, Inc. USB 2.0 (rev 51) (prog-if 20 [EHCI])
        Subsystem: Asustek Computer, Inc.: Unknown device 8080
        Flags: bus master, medium devsel, latency 32, IRQ 10
        Memory at dc800000 (32-bit, non-prefetchable) [size=256]
        Capabilities: [80] Power Management version 2

00:0d.0 Ethernet controller: Digital Equipment Corporation DECchip 21140
[FasterNet] (rev 20)
        Subsystem: D-Link System Inc DFE-500TX Fast Ethernet
        Flags: bus master, medium devsel, latency 32, IRQ 11
        I/O ports at b800 [size=128]
        Memory at dc000000 (32-bit, non-prefetchable) [size=128]
        Expansion ROM at <unassigned> [disabled] [size=256K]

00:11.0 ISA bridge: VIA Technologies, Inc. VT8233A ISA Bridge
        Subsystem: Asustek Computer, Inc.: Unknown device 808c
        Flags: bus master, stepping, medium devsel, latency 0
        Capabilities: [c0] Power Management version 2

00:11.1 IDE interface: VIA Technologies, Inc. Bus Master IDE (rev 06) (prog-if
8a [Master SecP PriP])
        Subsystem: Asustek Computer, Inc.: Unknown device 808c
        Flags: bus master, medium devsel, latency 32
        I/O ports at b400 [size=16]
        Capabilities: [c0] Power Management version 2

00:11.2 USB Controller: VIA Technologies, Inc. USB (rev 23) (prog-if 00 [UHCI])
        Subsystem: Asustek Computer, Inc.: Unknown device 808c
        Flags: bus master, medium devsel, latency 32, IRQ 5
        I/O ports at b000 [size=32]
        Capabilities: [80] Power Management version 2

00:11.3 USB Controller: VIA Technologies, Inc. USB (rev 23) (prog-if 00 [UHCI])
        Subsystem: Asustek Computer, Inc.: Unknown device 808c
        Flags: bus master, medium devsel, latency 32, IRQ 5
        I/O ports at a800 [size=32]
        Capabilities: [80] Power Management version 2

01:00.0 VGA compatible controller: nVidia Corporation NV4 [Riva TnT] (rev 04)
(prog-if 00 [VGA])
        Subsystem: Asustek Computer, Inc. V3400 TNT
        Flags: bus master, 66Mhz, medium devsel, latency 64, IRQ 11
        Memory at dd000000 (32-bit, non-prefetchable) [size=16M]
        Memory at df000000 (32-bit, prefetchable) [size=16M]
        Expansion ROM at deff0000 [disabled] [size=64K]
        Capabilities: [60] Power Management version 1
        Capabilities: [44] AGP version 1.0
Comment 5 Pete Zaitcev 2002-06-04 13:22:20 EDT
OK, so it's EHCI. Trying usb-ohci with it is not going to work.
The community driver is ehci-hcd.

Note You need to log in before you can comment on or make changes to this bug.