Bug 6393 - VJ header compression bug?
VJ header compression bug?
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
6.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Alan Cox
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-10-26 15:33 EDT by mcmillan
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-02-06 00:11:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description mcmillan 1999-10-26 15:33:33 EDT
After upgrading from RH5.2 to RH6.1, I had intermittent
failures with ppp. That is, I could connect every time,
but on some connections TCP connections did not work.
Control packets (i.e., ping) and DNS always worked.

At the suggestion of someone on comp.os.linux.networking,
I disabled the "VJ header compression" with the "novj"
option in /etc/ppp/options, and this *seems* to have solved
the problem (can't be 100% sure, since the problem was
intermittent).

While this could be a problem at the server end, it seems
unlikely, since ppp was working fine with RH5.2, without
using "novj". If someone can explain to me how to log the
kernel ppp activity, I can perhaps provide better
information on what's going wrong (I tried using the pppd
"debug" option, but that seems to show only the protocol
startup, and doesn't show any IP traffic).

	Ken McMillan
Comment 1 Alan Cox 1999-11-08 10:44:59 EST
Quite a few servers get vj compression with options wrong. You may
find disabling sack and time stamps has a similar #fixing'
effect. For real world use SACK is worth more than VJ except on very
reliable links

Note You need to log in before you can comment on or make changes to this bug.