Bug 639313 - elements with empty name in the configuration store
elements with empty name in the configuration store
Status: CLOSED ERRATA
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: wallaby (Show other bugs)
1.3
All Linux
low Severity medium
: 1.3.2
: ---
Assigned To: Will Benton
Martin Kudlej
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-10-01 08:28 EDT by Lubos Trilety
Modified: 2011-02-15 07:17 EST (History)
4 users (show)

See Also:
Fixed In Version: wallaby-0.9.21-1
Doc Type: Bug Fix
Doc Text:
Previously, the wallaby API allowed API clients to create configuration entities with empty names. This behavior made it difficult to query for these elements with the command-line tools because configuration entities are identified by name. With this update, the wallaby API disallows the creation of entities with empty names. Now, the wallaby service rejects attempts to create entities with empty names.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-02-15 07:17:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lubos Trilety 2010-10-01 08:28:23 EDT
Description of problem:
It is possible to create element in the store (like parameter, feature, ...) with empty name using wallaby utility. Other tools like condor_configure_store/pool are not able to work with such elements.

Version-Release number of selected component (if applicable):
wallaby-utils-0.9.18-2.el5

How reproducible:
100%

Steps to Reproduce:
1. run 'wallaby console'
2. create parameter with empty name using 'wallaby console'
> Wallaby::store.addParam('')
3. list all parameters
# condor_configure_store --list-all-params
or get parameter with empty name
# wallaby console
Console Connection Established...
> par=Wallaby::store.getParam('')

Actual results:
The parameter with empty name is created, it can be checked with
# condor_configure_store --list-all-params
or
# wallaby console
Console Connection Established...
> par=Wallaby::store.getParam('')

Expected results:
The element was not created, proper error message is printed.

Additional info:
Comment 1 Will Benton 2010-10-01 18:06:19 EDT
Fixed in master; will be packaged sometime in the future.
Comment 2 Will Benton 2010-11-25 16:30:30 EST
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
C:  The wallaby API previously allowed API clients to create configuration entities with empty names.
C:  Because configuration entities are identified by name, this made it difficult to query for these elements by using the command-line tools.
F:  The wallaby API no longer allows creating entities with empty names.
R:  Attempts to create entities with empty names will be rejected with an error by the wallaby service.
Comment 4 Martin Kudlej 2011-01-10 09:44:28 EST
Reproduced on RHEL 5.6 x i386/x86_64 with:
ruby-wallaby-0.9.18-2.el5
condor-wallaby-client-3.6-6.el5
wallaby-0.9.18-2.el5
python-wallabyclient-3.6-6.el5
condor-wallaby-base-db-1.4-5.el5
condor-wallaby-tools-3.6-6.el5
wallaby-utils-0.9.18-2.el5

and it didn't work.
Comment 5 Martin Kudlej 2011-01-10 10:19:09 EST
Tested on RHEL 5.6 x i386/x86_64 with:

wallaby-utils-0.10.0-2.el5
wallaby-0.10.0-2.el5
condor-wallaby-base-db-1.5-2.el5
ruby-wallaby-0.10.0-2.el5
condor-wallaby-tools-3.8-8.el5
condor-wallaby-client-3.8-8.el5
python-wallabyclient-3.8-8.el5

and it works. --> VERIFIED
Comment 6 Florian Nadge 2011-02-09 11:47:22 EST
    Technical note updated. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    Diffed Contents:
@@ -1,4 +1 @@
-C:  The wallaby API previously allowed API clients to create configuration entities with empty names.
+Previously, the wallaby API allowed API clients to create configuration entities with empty names. This behavior it was difficult to query for these elements with the command-line tools because configuration entities are identified by name. With this update, the wallaby API disallows the creation of entities with empty names. Now, the wallaby service rejects attempts to create entities with empty names.-C:  Because configuration entities are identified by name, this made it difficult to query for these elements by using the command-line tools.
-F:  The wallaby API no longer allows creating entities with empty names.
-R:  Attempts to create entities with empty names will be rejected with an error by the wallaby service.
Comment 7 Florian Nadge 2011-02-09 12:49:12 EST
    Technical note updated. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    Diffed Contents:
@@ -1 +1 @@
-Previously, the wallaby API allowed API clients to create configuration entities with empty names. This behavior it was difficult to query for these elements with the command-line tools because configuration entities are identified by name. With this update, the wallaby API disallows the creation of entities with empty names. Now, the wallaby service rejects attempts to create entities with empty names.+Previously, the wallaby API allowed API clients to create configuration entities with empty names. This behavior made it difficult to query for these elements with the command-line tools because configuration entities are identified by name. With this update, the wallaby API disallows the creation of entities with empty names. Now, the wallaby service rejects attempts to create entities with empty names.
Comment 8 errata-xmlrpc 2011-02-15 07:17:26 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-0217.html

Note You need to log in before you can comment on or make changes to this bug.