Bug 63948 - Bad error message for chosing invalid port
Summary: Bad error message for chosing invalid port
Status: CLOSED RAWHIDE
Alias: None
Product: Stronghold Cross Platform
Classification: Retired
Component: configurator (Show other bugs)
(Show other bugs)
Version: 4.0
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Mark J. Cox
QA Contact: Stronghold Engineering List
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-04-22 15:29 UTC by Joe Orton
Modified: 2007-04-18 16:42 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-22 15:29:07 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Joe Orton 2002-04-22 15:29:03 UTC
If installing as a non-root user, if the user tries to select a port below <1024,
the error message will be:

     You cannot use that port because Permission denied.                       
                Please select a different port number

Should present EPERM errors nicely, and/or separate the error message from
strerror() with a colon.


Note You need to log in before you can comment on or make changes to this bug.