Bug 63993 - LDAP MODRDN Crashes slave servers
LDAP MODRDN Crashes slave servers
Status: CLOSED CANTFIX
Product: Red Hat Linux
Classification: Retired
Component: openldap (Show other bugs)
7.2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jay Fenlason
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-04-23 09:42 EDT by Thais Smith
Modified: 2014-08-31 19:24 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-18 13:23:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thais Smith 2002-04-23 09:42:24 EDT
Description of Problem:  
  
OpenLDAP slave servers fall over dead when a MODRDN propagates to them from  
the master. Their database then ends up in an inconsistent state where the  
new name exists but the old name is returned by searches. The old name can be  
deleted but the new name is still not returned by searches and cannot be  
updated (though attempts to create it fail because "it already exists")  
  
Version-Release number of selected component (if applicable):  
  
openldap-2.0.21. ChangeLog suggests it may be fixed in 2.0.23. A bugfix 
package in RHN would be a nice thing to have.  
  
How Reproducible:  
  
Always  
  
Steps to Reproduce:  
1. Set up an LDAP server  
2. Set up a second LDAP server as a slave of the first  
3. Create an entry in the master server. Watch it propagate to the slave  
4. Use a tool such as 'gq' to change the RDN of the entry.  
5. Watch the MODRDN propagate to the slave  
6. Watch the slave fall over dead with its database in an inconsistent state.  
  
Actual Results:  
  
Slave dies. Running the slave with slapd -d 255 reveals that it triggers the  
'assert(0)' on line 948 of servers/slapd/acl.c  
  
Expected Results:  
  
This should work. At least if you want to use LDAP on more than one central  
server :-)  
  
Additional Information:
Comment 1 Bill Nottingham 2006-08-07 16:02:27 EDT
Red Hat Linux is no longer supported by Red Hat, Inc. If you are still
running Red Hat Linux, you are strongly advised to upgrade to a
current Fedora Core release or Red Hat Enterprise Linux or comparable.
Some information on which option may be right for you is available at
http://www.redhat.com/rhel/migrate/redhatlinux/.

Red Hat apologizes that these issues have not been resolved yet. We do
want to make sure that no important bugs slip through the cracks.
Please check if this issue is still present in a current Fedora Core
release. If so, please change the product and version to match, and
check the box indicating that the requested information has been
provided. Note that any bug still open against Red Hat Linux on will be
closed as 'CANTFIX' on September 30, 2006. Thanks again for your help.
Comment 2 Bill Nottingham 2006-10-18 13:23:33 EDT
Red Hat Linux is no longer supported by Red Hat, Inc. If you are still
running Red Hat Linux, you are strongly advised to upgrade to a
current Fedora Core release or Red Hat Enterprise Linux or comparable.
Some information on which option may be right for you is available at
http://www.redhat.com/rhel/migrate/redhatlinux/.

Closing as CANTFIX.

Note You need to log in before you can comment on or make changes to this bug.