Bug 64015 - rpm ignores %setup -q with zipped sources
rpm ignores %setup -q with zipped sources
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: rpm-build (Show other bugs)
7.2
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Jeff Johnson
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-04-23 16:13 EDT by Ville Skyttä
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-05-02 13:59:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Make rpm respect %setup -q with zipped sources (465 bytes, patch)
2002-04-23 16:15 EDT, Ville Skyttä
no flags Details | Diff

  None (edit)
Description Ville Skyttä 2002-04-23 16:13:57 EDT
rpm does not respect the -q option of the %setup macro when dealing with zipped sources. 
When in quiet mode, unzip should have the -q option. 
 
I'll attach a (completely untested) patch against the current rpm CVS.
Comment 1 Ville Skyttä 2002-04-23 16:15:20 EDT
Created attachment 55044 [details]
Make rpm respect %setup -q with zipped sources
Comment 2 Jeff Johnson 2002-08-07 19:11:35 EDT
This went into rpm-4.1 yesterday, should be
in rpm-4.1-0.75.

Note You need to log in before you can comment on or make changes to this bug.