Bug 64021 - http kills eth0 on USB cable modem
Summary: http kills eth0 on USB cable modem
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
(Show other bugs)
Version: 7.2
Hardware: i686 Linux
medium
high
Target Milestone: ---
Assignee: Pete Zaitcev
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-04-23 22:03 UTC by Mike Kinghan
Modified: 2007-04-18 16:42 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-12-17 03:17:36 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Possible fix from Brad Hards (4.60 KB, patch)
2002-10-18 17:09 UTC, Pete Zaitcev
no flags Details | Diff

Description Mike Kinghan 2002-04-23 22:03:26 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-GB; rv:0.9.4) Gecko/20011019
Netscape6/6.2

Description of problem:
I'm running Red Hat 7.2 kernel 2.4.7-10 installed clean on a Dell Dimension XPS
T500, connecting to the internet via USB with a Turbonet cable modem on eth0.

My ip connection is fine (ping OK, ftp OK) until I launch an hhtp URL
in a browser - any browser. Then the browser churns and eventually
returns "timeout on server". eth0 is then dead - ifup fails and the
following two diagnostics are appended to the syslog:

Apr 21 15:38:05 pc2-oxfo3-0-cust67 kernel: usb-uhci.c: interrupt, status 3, frame# 0

Apr 21 15:38:05 pc2-oxfo3-0-cust67 kernel: CDCEther.c: read_bulk_callback failed
submint rx_urb -32

The boot log contains 2 earlier problematic messages whose relevance I
cannot assess:

Apr 21 15:35:26 pc2-oxfo3-0-cust67 kernel: CDCEther.c: eth0: set too many MC filters
...
Apr 21 15:35:54 pc2-oxfo3-0-cust67 xinetd[1322]: warning: can't get client
address: Transport endpoint is not connected

This cable modem setup functions fine for Win98 dual booted on the
same machine.



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Ensure that system has functioning internet connection for ping,
commandline ftp, browser ftp, via Turbonet cable modem on USB to eth0

2 Open any browser and enter any http URL


3.
	

Actual Results:  Browser churns, eventually returns timeout of server.
Ping <any remote address> returns "destination network unreachable".
ifup fails.
/var/log/messages has 2 new diagnostics as per summary.


Expected Results:  Browser should have returned web page from requested URL

Additional info:

Comment 1 Pete Zaitcev 2002-06-17 22:29:34 UTC
Is it possible to install kernel 2.4.9-34 and check if that works?
I understand it may be difficult if Internet does not work...
But I do have serious doubts about CDCEther in ancient kernels.
In fact the best would be to go directly to 2.4.18-3
(shipped with RH 7.3).


Comment 2 Mike Kinghan 2002-07-02 13:39:31 UTC
I installed 7.3, kernel 2.4.18-3 to see how that fared. It has
CDCEther 0.98.5.

It's slightly better. I can still browse ftp URLs, and can't browse
any http URLs, but now, when the browser times out, I still have a
functioning network on eth0. But since I can't get the Web, this is
still a Windows household.

Suspect diagnostic now appearing in the boot log is:

Jul  2 13:29:07 pc2-oxfd1-3-cust88 kernel: CDCEther.c: eth0: set too many MC 
filters, using allmulti

And after http browsing has bombed, I get the like of this:

Jul  2 13:32:18 pc2-oxfd1-3-cust88 kernel: usb-uhci.c: interrupt, status 3, 
frame# 2006

repeated many times with different frame numbers.

I tried out Mandrake 8.2 in between R.H. 7.2 and 7.3, and the
behaviour was the same as I've described here.


Comment 3 Pete Zaitcev 2002-10-18 17:09:03 UTC
Created attachment 80950 [details]
Possible fix from Brad Hards

Comment 4 Pete Zaitcev 2002-10-18 18:08:45 UTC
Requestor, please identify if you can build kernels and test patches,
or you need a binary RPM.


Comment 5 Pete Zaitcev 2003-02-03 21:47:52 UTC
Can you try a kernel from beta (2.4.20-2.24 currently)?
It has the infamous '^' instead of '%' in CDCEther.c



Note You need to log in before you can comment on or make changes to this bug.