Bug 64024 - dhcpcd accepts ilegal caracters
Summary: dhcpcd accepts ilegal caracters
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: dhcpcd (Show other bugs)
(Show other bugs)
Version: 7.2
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Elliot Lee
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-04-24 00:21 UTC by Carlos
Modified: 2007-04-18 16:42 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-28 17:23:18 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Carlos 2002-04-24 00:21:33 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i586; en-US; rv:0.9.4.1) Gecko/20020314
Netscape6/6.2.2

Description of problem:
My ISP is setting my hostname with DHCP using caracter "a" plus the dinamic IP,
replacing the dots with caracter "-".
Example: to IP 212.113.168.20 corresponds the hostname a212-113-168-20
As this hostname is ilegal for several services they don't start during the boot
sequence (lpd has to be started manualy after changing the hostname to a new
name without "-".


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.boot
2.
3.
	

Expected Results:  When these caracters occur, the hostame should:
1 -> remain unchanged, or
2 -> the name should have the ilegal caracters replaced by others (underscore )

Additional info:

Comment 1 Elliot Lee 2002-04-24 02:40:20 UTC
The hyphen character is legal in hostnames, the underscore is not. Perhaps lpd
is the confused party.


Comment 2 Carlos 2002-04-24 21:59:30 UTC
I just re-cheked and I think the problem is that the hostname set by dhcp can't
be resolved. Gnome can't resolve the name when started, lpd also can't.
Setting a new hostname only works if it is manually added to /etc/hosts which
isn't updated by dhcp.
I found that the same situation is reported in bug 55173.


Note You need to log in before you can comment on or make changes to this bug.