Bug 64029 - up2date segfaults when invoked
up2date segfaults when invoked
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: up2date (Show other bugs)
7.0
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Adrian Likins
Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-04-24 01:49 EDT by Ryan Hodges
Modified: 2015-01-07 18:56 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-26 04:55:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ryan Hodges 2002-04-24 01:49:44 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.4) Gecko/20011019
Netscape6/6.2

Description of problem:
up2date crashes when invoked.  A dialog box pops up indicating that
python actually crashes.  

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. up2date
2.
3.
	

Actual Results:  A dialog box pops up indicating that python crashes.  Bug buddy
allows me to collect the following debugging information:

Debugging Information:

(no debugging symbols found)...[New Thread 1024 (LWP 2191)]
0x4011c429 in __wait4 () from /lib/libc.so.6
#0  0x4011c429 in __wait4 () from /lib/libc.so.6
#1  0x40199cb4 in __DTOR_END__ () from /lib/libc.so.6
#2  0x400336d3 in waitpid (pid=2196, stat_loc=0xbffff2dc, options=0)
    at wrapsyscall.c:172
#3  0x40862822 in gnome_segv_handle (signum=11) at gnome-init.c:664
#4  0x400313bb in pthread_sighandler (signo=11, ctx=
      {gs = 0, __gsh = 0, fs = 0, __fsh = 0, es = 43, __esh = 0, ds = 43, __dsh
= 0, edi = 3221223188, esi = 0, ebp = 3221222616, esp = 3221222528, ebx = 0, edx
= 134900612, ecx = 3221223204, eax = 0, trapno = 14, err = 6, eip = 134723768,
cs = 35, __csh = 0, eflags = 66067, esp_at_signal = 3221222528, ss = 43, __ssh =
0, fpstate = 0xbffff400, oldmask = 2147483648, cr2 = 0}) at signals.c:97
#5  <signal handler called>
#6  0x0807b8b8 in PyArg_VaParse ()
#7  0x0807b76c in PyArg_VaParse ()
#8  0x0807b730 in PyArg_VaParse ()
#9  0x0807b3f1 in PyArg_VaParse ()
#10 0x0807b083 in PyArg_ParseTuple ()
#11 0x404f5c58 in _wrap_gdk_color_new (self=0x0, args=0x81a93a8)
    at gtkmodule.c:5951
#12 0x080547a8 in PyEval_CallObjectWithKeywords ()
#13 0x080546ad in PyEval_CallObjectWithKeywords ()
#14 0x0805368a in PyEval_EvalCode ()
#15 0x08053568 in PyEval_EvalCode ()
#16 0x08054ad1 in PyEval_CallObjectWithKeywords ()
#17 0x0805469f in PyEval_CallObjectWithKeywords ()
#18 0x08068b17 in PyInstance_New ()
#19 0x080546ad in PyEval_CallObjectWithKeywords ()
#20 0x0805368a in PyEval_EvalCode ()
#21 0x08053568 in PyEval_EvalCode ()
#22 0x08053568 in PyEval_EvalCode ()
#23 0x0805154e in PyEval_EvalCode ()
#24 0x08061698 in PyRun_File ()
#25 0x08060d41 in PyRun_SimpleFile ()
#26 0x0804fde8 in Py_Main ()
#27 0x4007d6f7 in __libc_start_main (main=0x804f87c <main>, argc=3, 
    ubp_av=0xbffffe74, init=0x804ee50 <_init>, fini=0x80891cc <_fini>, 
    rtld_fini=0x4000dcd4 <_dl_fini>, stack_end=0xbffffe6c)
    at ../sysdeps/generic/libc-start.c:129

Thread 1 (Thread 1024 (LWP 2191)):
#0  0x4011c429 in __wait4 () from /lib/libc.so.6
#1  0x40199cb4 in __DTOR_END__ () from /lib/libc.so.6
#2  0x400336d3 in waitpid (pid=2196, stat_loc=0xbffff2dc, options=0)
    at wrapsyscall.c:172
#3  0x40862822 in gnome_segv_handle (signum=11) at gnome-init.c:664
#4  0x400313bb in pthread_sighandler (signo=11, ctx=
      {gs = 0, __gsh = 0, fs = 0, __fsh = 0, es = 43, __esh = 0, ds = 43, __dsh
= 0, edi = 3221223188, esi = 0, ebp = 3221222616, esp = 3221222528, ebx = 0, edx
= 134900612, ecx = 3221223204, eax = 0, trapno = 14, err = 6, eip = 134723768,
cs = 35, __csh = 0, eflags = 66067, esp_at_signal = 3221222528, ss = 43, __ssh =
0, fpstate = 0xbffff400, oldmask = 2147483648, cr2 = 0}) at signals.c:97
#5  <signal handler called>
#6  0x0807b8b8 in PyArg_VaParse ()
#7  0x0807b76c in PyArg_VaParse ()
#8  0x0807b730 in PyArg_VaParse ()
#9  0x0807b3f1 in PyArg_VaParse ()
#10 0x0807b083 in PyArg_ParseTuple ()
#11 0x404f5c58 in _wrap_gdk_color_new (self=0x0, args=0x81a93a8)
    at gtkmodule.c:5951
#12 0x080547a8 in PyEval_CallObjectWithKeywords ()
#13 0x080546ad in PyEval_CallObjectWithKeywords ()
#14 0x0805368a in PyEval_EvalCode ()
#15 0x08053568 in PyEval_EvalCode ()
#16 0x08054ad1 in PyEval_CallObjectWithKeywords ()
#17 0x0805469f in PyEval_CallObjectWithKeywords ()
#18 0x08068b17 in PyInstance_New ()
#19 0x080546ad in PyEval_CallObjectWithKeywords ()
#20 0x0805368a in PyEval_EvalCode ()
#21 0x08053568 in PyEval_EvalCode ()
#22 0x08053568 in PyEval_EvalCode ()
#23 0x0805154e in PyEval_EvalCode ()
#24 0x08061698 in PyRun_File ()
#25 0x08060d41 in PyRun_SimpleFile ()
#26 0x0804fde8 in Py_Main ()
#27 0x4007d6f7 in __libc_start_main (main=0x804f87c <main>, argc=3, 
    ubp_av=0xbffffe74, init=0x804ee50 <_init>, fini=0x80891cc <_fini>, 
    rtld_fini=0x4000dcd4 <_dl_fini>, stack_end=0xbffffe6c)
    at ../sysdeps/generic/libc-start.c:129
#0  0x4011c429 in __wait4 () from /lib/libc.so.6
#0  0x4011c429 in __wait4 () from /lib/libc.so.6
No locals.
#1  0x40199cb4 in __DTOR_END__ () from /lib/libc.so.6
No symbol table info available.
#2  0x400336d3 in waitpid (pid=2196, stat_loc=0xbffff2dc, options=0)
    at wrapsyscall.c:172
	in wrapsyscall.c
stat_loc = (int *) 0xbffff2dc
options = 0
result = 0
oldtype = 0
#3  0x40862822 in gnome_segv_handle (signum=11) at gnome-init.c:664
	in gnome-init.c
estatus = 20
in_segv = 1
pid = 0
#4  0x400313bb in pthread_sighandler (signo=11, ctx=
      {gs = 0, __gsh = 0, fs = 0, __fsh = 0, es = 43, __esh = 0, ds = 43, __dsh
= 0, edi = 3221223188, esi = 0, ebp = 3221222616, esp = 3221222528, ebx = 0, edx
= 134900612, ecx = 3221223204, eax = 0, trapno = 14, err = 6, eip = 134723768,
cs = 35, __csh = 0, eflags = 66067, esp_at_signal = 3221222528, ss = 43, __ssh =
0, fpstate = 0xbffff400, oldmask = 2147483648, cr2 = 0}) at signals.c:97
	in signals.c
self = 0x4003a4c0
in_sighandler = 0x0
self = 0x4003a4c0
in_sighandler = 0x0
#5  <signal handler called>
No locals.
#6  0x0807b8b8 in PyArg_VaParse ()
No symbol table info available.
#7  0x0807b76c in PyArg_VaParse ()
No symbol table info available.

In addition the following output is printed to the tty:
[ryan@odyssey rhn]$ up2date
/etc/sysconfig/rhn/2191: No such file or directory.
172
wrapsyscall.c: No such file or directory.
664
gnome-init.c: No such file or directory.
97
signals.c: No such file or directory.

Expected Results:  up2date should have updated my packages

Additional info:
Comment 1 Adrian Likins 2002-04-24 14:47:01 EDT
>> Version-Release number of selected component (if applicable):
    what version of up2date?

Looks like something down in pygtk, so what version of
pygtk as well?

Anything unusual about the X setup on this box? (color depth,
in particular...)


>> [ryan@odyssey rhn]$ up2date
>> /etc/sysconfig/rhn/2191: No such file or directory.
>> 172
>> wrapsyscall.c: No such file or directory.
>> 664
>> gnome-init.c: No such file or directory.
>> 97
>> signals.c: No such file or directory.

hmmm, weird. Never seen that before. offhand, I've got no idea why
it would be complaining abount "wrapsyscall.c: No such file or directory."
and the like. My guess for that output would be bug-buddy weirdness, since
up2date doesnt ever try to access that kind of code.
Comment 2 Ryan Hodges 2002-04-25 01:14:20 EDT
Versions of pygtk and up2date

[root@odyssey up2date]# rpm -q pygtk
pygtk-0.6.9-1.ximian.1
[root@odyssey up2date]# rpm -q up2date
up2date-2.7.61-7.x.1
[root@odyssey up2date]# 

X configuration

[root@odyssey bin]# xdpyinfo 
name of display:    :0.0
version number:    11.0
vendor string:    The XFree86 Project, Inc
vendor release number:    4001
maximum request size:  4194300 bytes
motion buffer size:  256
bitmap unit, bit order, padding:    32, LSBFirst, 32
image byte order:    LSBFirst
number of supported pixmap formats:    6
supported pixmap formats:
    depth 1, bits_per_pixel 1, scanline_pad 32
    depth 4, bits_per_pixel 8, scanline_pad 32
    depth 8, bits_per_pixel 8, scanline_pad 32
    depth 15, bits_per_pixel 16, scanline_pad 32
    depth 16, bits_per_pixel 16, scanline_pad 32
    depth 24, bits_per_pixel 32, scanline_pad 32
keycode range:    minimum 8, maximum 255
focus:  window 0x100009e, revert to Parent
number of extensions:    28
    BIG-REQUESTS
    DOUBLE-BUFFER
    DPMS
    Extended-Visual-Information
    FontCache
    GLX
    LBX
    MIT-SCREEN-SAVER
    MIT-SHM
    MIT-SUNDRY-NONSTANDARD
    RECORD
    SECURITY
    SGI-GLX
    SHAPE
    SYNC
    TOG-CUP
    X3D-PEX
    XC-APPGROUP
    XC-MISC
    XFree86-Bigfont
    XFree86-DGA
    XFree86-Misc
    XFree86-VidModeExtension
    XIE
    XInputExtension
    XKEYBOARD
    XTEST
    XVideo
default screen number:    0
number of screens:    1

screen #0:
  dimensions:    1152x864 pixels (370x271 millimeters)
  resolution:    79x81 dots per inch
  depths (1):    16
  root window id:    0x28
  depth of root window:    16 planes
  number of colormaps:    minimum 1, maximum 1
  default colormap:    0x21
  default number of colormap cells:    64
  preallocated pixels:    black 0, white 65535
  options:    backing-store NO, save-unders NO
  largest cursor:    32x32
  current input event mask:    0x5a20bd
    KeyPressMask             ButtonPressMask          ButtonReleaseMask        
    EnterWindowMask          LeaveWindowMask          PointerMotionHintMask    
    ButtonMotionMask         StructureNotifyMask      SubstructureNotifyMask   
    SubstructureRedirectMask PropertyChangeMask       
  number of visuals:    2
  default visual id:  0x23
  visual:
    visual id:    0x23
    class:    TrueColor
    depth:    16 planes
    available colormap entries:    64 per subfield
    red, green, blue masks:    0xf800, 0x7e0, 0x1f
    significant bits in color specification:    6 bits
  visual:
    visual id:    0x24
    class:    TrueColor
    depth:    16 planes
    available colormap entries:    64 per subfield
    red, green, blue masks:    0xf800, 0x7e0, 0x1f
    significant bits in color specification:    6 bits
[root@odyssey bin]#
Comment 3 Adrian Likins 2002-04-25 12:43:59 EDT
>> [root@odyssey up2date]# rpm -q pygtk
>> pygtk-0.6.9-1.ximian.1

If I had to pick a first target, that would be it. I belive that
the current versions of ximians pygtk is okay, but their pygtk has
been broken a few times in the past that caused up2date to segfault.

Try replacing it with the original pygtk package, and see if
the segfault is still around.
Comment 4 Ryan Hodges 2002-04-26 04:55:06 EDT
Someone else recommended that same strategy.  I'll just assume that's the
problem.    At this point in time, I don't want to swap the pygtk package out. 
I use this machine primarily for work and I can't afford to break something
else.  I'll wait for Ximian to release another version of pygtk.  


Note You need to log in before you can comment on or make changes to this bug.