Bug 64072 - PCMCIA does not work on DELL Latitude LM
PCMCIA does not work on DELL Latitude LM
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: kernel-pcmcia-cs (Show other bugs)
7.3
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-04-24 22:30 EDT by Eugene Kanter
Modified: 2015-01-04 17:01 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-25 02:21:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eugene Kanter 2002-04-24 22:30:55 EDT
Description of Problem:

lspci:

00:04.0 PCMCIA bridge: Cirrus Logic CL 6729 (rev fe)
        Flags: stepping, slow devsel
        I/O ports at fcfc [size=4]

Version-Release number of selected component (if applicable):

kernel-pcmcia-cs-3.1.27-14

How Reproducible:

always

Steps to Reproduce:
1. boot disks do not recognize PCMCIA, network install not possible.
2. install from CDROM, PCMCIA still not recognized.
3. 

Additional Information:
	
Апр 23 00:04:26 localhost pcmcia: Starting PCMCIA services:
Апр 23 00:04:26 localhost pcmcia:  modules
Apr 23 00:04:26 localhost kernel: Linux Kernel Card Services 3.1.22
Apr 23 00:04:26 localhost kernel:   options:  [pci] [cardbus] [pm]
Apr 23 00:04:26 localhost kernel: Intel PCIC probe: not found.
Апр 23 00:04:26 localhost pcmcia: /lib/modules/2.4.18-0.13/pcmcia/i82365.o:
Апр 23 00:04:26 localhost pcmcia: Hint: insmod errors can be caused by incorrect
module parameters, including invalid IO or IRQ parametersАпр 23 00:04:26
localhost pcmcia: init_module: No such device
Apr 23 00:04:26 localhost kernel: ds: no socket drivers loaded!
Апр 23 00:04:26 localhost pcmcia: /lib/modules/2.4.18-0.13/pcmcia/ds.o:
Апр 23 00:04:26 localhost pcmcia: Hint: insmod errors can be caused by incorrect
module parameters, including invalid IO or IRQ parametersАпр 23 00:04:26
localhost pcmcia:  cardmgr.
Апр 23 00:04:26 localhost pcmcia: init_module: Operation not permitted
Apr 23 00:04:27 localhost cardmgr[579]: starting, version is 3.1.22
Апр 23 00:04:27 localhost rc: Starting pcmcia:  succeeded
Apr 23 00:04:27 localhost cardmgr[579]: config error, file './config.opts' line
8: no function bindings
Apr 23 00:04:27 localhost cardmgr[579]: no pcmcia driver in /proc/devices
Apr 23 00:04:27 localhost cardmgr[579]: exiting
Comment 1 Eugene Kanter 2002-04-24 22:53:50 EDT
Red Hat 6.2 works with no problem at all.
Comment 2 Arjan van de Ven 2002-06-03 15:08:39 EDT
Is this a somewhat older laptop ?
Comment 3 Eugene Kanter 2002-06-04 18:07:31 EDT
Yes, it is. I was told that PCI/PCMCIA adapters are not supported by 2.4 kernel
pcmcia drivers. Any chance it might get supported? Should there be a special
kernel with old pcmcia-cs drivers to support older hardware?
Comment 4 Arjan van de Ven 2002-06-05 04:09:32 EDT
Well there is the chicken vs egg problem here. I already wrote a PCI->pcmcia
driver for one chip, but the most common chip I don't have hw access for so
can't actually write the driver ;(

Comment 5 Eugene Kanter 2003-10-19 21:02:40 EDT
Any news here?
According to pcmcia-cs documentation PCI to PCMCIA adapters will never be
supported by kernel PCMCIA subsystem. Does this mean that these adapters are
essentially dead and not worth supporting anymore?

Note You need to log in before you can comment on or make changes to this bug.