Bug 640792 - Fedora 14 nfs service does not work
Fedora 14 nfs service does not work
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: nfs-utils (Show other bugs)
14
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Steve Dickson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-10-06 15:37 EDT by Eric Sokolowsky
Modified: 2010-12-01 12:08 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-12-01 12:08:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Eric Sokolowsky 2010-10-06 15:37:27 EDT
Description of problem:

Fedora 14 does not properly serve files with nfs, even to same host.

Version-Release number of selected component (if applicable):


How reproducible:

Always. 

Steps to Reproduce:
1. [ edit /etc/exportfs to export any mounted directory to local subnet ]
2. service nfs start
3. mkdir /mnt/test
4. mount -t nfs -o rw,hard,intr,bg xxx:/path /mnt/test
  
Actual results:

A message onscreen that the request is being backgrounded; multiple messages in /var/log/messages: "mount to NFS server '192.168.10.1' failed: Stale NFS file handle, retrying"

Expected results:

mounted filesystem

Additional info:

Tested on Mac Mini 2010 model running Fedora 14 beta, kernel 2.6.35.4-28.fc14.x86_64 or kernel 2.6.35.6-37.fc14.x86_64. I also tried the same steps on Fedora 13 and it worked without trouble. I tried to use Fedora 14 as the client and Fedora 13 as the NFS server and was successful. I was unable to use Fedora 13 as the client and Fedora 14 as the server; the Fedora 13 machine showed exactly the same symptoms and didn't mount the volume.
Comment 1 Steve Dickson 2010-10-15 19:01:00 EDT
Please update to the latest nfs-utils vers

https://admin.fedoraproject.org/updates/nfs-utils-1.2.3-1.fc14

to see if the problem still exists. tia...
Comment 2 Eric Sokolowsky 2010-11-19 09:11:00 EST
Testing after updating to Fedora 14 Release solved problem. Thank you.

Note You need to log in before you can comment on or make changes to this bug.