Bug 640924 - [isdn4k-utils] boot warning due to name mismatch in udev rules
Summary: [isdn4k-utils] boot warning due to name mismatch in udev rules
Status: CLOSED DUPLICATE of bug 598757
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel   
(Show other bugs)
Version: 14
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-10-07 08:20 UTC by Joachim Frieben
Modified: 2010-10-07 10:01 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-10-07 10:00:34 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Joachim Frieben 2010-10-07 08:20:53 UTC
Description of problem:
During the start-up of a fully updated F14 system, the following warning is issued:

 "udevd-work[546]: kernel-provided name 'capi' and NAME= 'capi20' disagree,
  please use SYMLINK+= or change the kernel to provide the proper name"

Version-Release number of selected component (if applicable):
isdn4k-utils-3.2-71.fc14.x86_64

How reproducible:
Always.

Steps to Reproduce:
1. Boot system.
2. Check /var/log/boot.log
  
Actual results:
UDEV complains about a name mismatch capi (kernel) versus capi20 (udev).

Expected results:
No name mismatch occurs.

Additional info:
This issue is caused by /lib/udev/rules.d/40-isdn.rules which introduces name "capi20",

 'SUBSYSTEM=="capi", KERNEL=="capi", NAME="capi20", GROUP="dialout"
  SUBSYSTEM=="tty", KERNEL=="capi[0-9]*", NAME="capi/%n"'

Comment 1 Ngo Than 2010-10-07 10:00:34 UTC

*** This bug has been marked as a duplicate of bug 598757 ***


Note You need to log in before you can comment on or make changes to this bug.